Bug 1025748 - Darktable's background process is not closed after UI is closed
Darktable's background process is not closed after UI is closed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: darktable (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Edouard Bourguignon
Fedora Extras Quality Assurance
:
: 1048172 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 08:52 EDT by lionghostshop
Modified: 2015-02-01 09:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-01 09:31:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lionghostshop 2013-11-01 08:52:24 EDT
Description of problem:


Version-Release number of selected component (if applicable):
darktable-1.2.3-1.fc20.x86_64

How reproducible:


Steps to Reproduce:
1. Open darktable and edit a few files
2. close it
3. Restart it, it cannot be opened. In the terminal, it shows
[init] database is locked, probably another process is already using it.
4. Darktable can be re-started after kill darktable process. 


Additional info:
Comment 1 lionghostshop 2013-12-28 02:23:27 EST
I've reported the problem to upstream. It has been fixed in 1.4. 
Is there a chance to upgrade the version to 1.4?
Comment 2 Edouard Bourguignon 2013-12-28 03:33:36 EST
Thanks for this report, I will make a new rpm asap.
Comment 3 Edouard Bourguignon 2014-01-03 05:44:40 EST
*** Bug 1048172 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2014-01-03 05:56:51 EST
darktable-1.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/darktable-1.4-1.fc19
Comment 5 Fedora Update System 2014-01-03 05:56:59 EST
darktable-1.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/darktable-1.4-1.fc20
Comment 6 Fedora Update System 2014-01-03 18:23:10 EST
Package darktable-1.4-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing darktable-1.4-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0126/darktable-1.4-1.fc19
then log in and leave karma (feedback).
Comment 7 pindakoe 2014-01-05 08:47:46 EST
Works for me!
Comment 8 Fedora Update System 2014-01-15 02:28:47 EST
darktable-1.4-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/darktable-1.4-2.fc19
Comment 9 Fedora Update System 2014-01-15 02:29:04 EST
darktable-1.4-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/darktable-1.4-2.fc20
Comment 10 Fedora Update System 2014-01-24 02:42:10 EST
darktable-1.4-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 lionghostshop 2014-01-24 02:43:11 EST
It's fixed.
Comment 12 Fedora Update System 2014-02-08 22:55:25 EST
darktable-1.4-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.