Bug 1025776 - Platform trace log contains database gear password
Platform trace log contains database gear password
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
: 1045303 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 10:25 EDT by Andrew Butcher
Modified: 2017-03-08 12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-21 16:27:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Butcher 2013-11-01 10:25:55 EDT
Description of problem:
Creating application which includes database gear will log database credentials in /var/log/openshift/node/platform-trace.log.

Version-Release number of selected component (if applicable):
1.2.1

How reproducible:
Always

Steps to Reproduce:
1. Create app with database gear add on.


Actual results:
From /var/log/openshift/node/platform-trace.log:

CLIENT_RESULT: MySQL 5.1 database added.  Please make note of these credentials:
CLIENT_RESULT:        Root User: <ROOTUSERNAME>
CLIENT_RESULT:    Root Password: <ROOTPASSWORD>
CLIENT_RESULT:    Database Name: <dbname>
...
CART_PROPERTIES: username=<ROOTUSERNAME>
CART_PROPERTIES: password=<ROOTPASSWORD>
CART_PROPERTIES: database_name=<dbname>
...

Expected results:
Passwords are filtered out.

Additional info:
None
Comment 2 Johnny Liu 2014-01-02 07:09:29 EST
*** Bug 1045303 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.