Bug 1025780 - Cannot disable KSM
Cannot disable KSM
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
All Linux
medium Severity high
: ---
: 3.3.0
Assigned To: Amador Pahim
Lukas Svaty
sla
: Triaged
Depends On:
Blocks: GSS_RHEV_33_BETA 1026980
  Show dependency treegraph
 
Reported: 2013-11-01 10:44 EDT by Amador Pahim
Modified: 2016-02-10 15:18 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Users can now use the "ksmEnabled" parameter on vdsClient to enable or disable Kernel Samepage Merging (KSM) control by the Memory Overcommit Manager (MOM). By default, KSM is enabled.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:19:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20879 None None None Never
oVirt gerrit 21839 None None None Never
oVirt gerrit 22150 None None None Never
Red Hat Product Errata RHBA-2014:0040 normal SHIPPED_LIVE vdsm bug fix and enhancement update 2014-01-21 15:26:21 EST

  None (edit)
Description Amador Pahim 2013-11-01 10:44:18 EDT
Description of problem:

Up to RHEV 3.2, KSM was controlled by ksmtuned. Users wanting stop KSM just wanted to stop ksmtuned service.

In RHEV 3.3, vdsm stops ksmtuned and gives KSM control to MOM. MOM controls KSM and memory ballooning. 

We can disable memory ballooning using RHEV Admin Portal interface, unchecking "Enable Memory Balloon Optimization" in Cluster level, which will have effect in next Host "Up", or using emergencial vdsClient on the Hypervisor:

# vdsClient -s 0 setMOMPolicyParameters balloonEnabled=False

Please provide an equivalent way to disable KSM in RHEV 3.3.
Comment 8 Lukas Svaty 2013-12-17 05:26:36 EST
can you provide any information how to test this?
Comment 9 Martin Sivák 2013-12-17 05:30:54 EST
vdsClient -s 0 setMOMPolicyParameters ksmEnabled=False

This command should disable KSM. You can  then use MoM's xml-rpc, call getPolicy() and check if the ksmEnabled variable is indeed set to False. There will be two parts - (defvar ksmEnabled True) as a default and (set ksmEnabled False) representing the updated value.
Comment 10 Martin Sivák 2013-12-17 05:32:52 EST
Also please make sure that the value is still there when you subsequently call setMOMPolicyParameters with only balloonEnabled=False.

In other words:

vdsClient -s 0 setMOMPolicyParameters ksmEnabled=False
vdsClient -s 0 setMOMPolicyParameters balloonEnabled=False

should give you the same result as

vdsClient -s 0 setMOMPolicyParameters ksmEnabled=False balloonEnabled=False
Comment 11 Lukas Svaty 2013-12-17 05:39:36 EST
thanks Martin,
tested in is28 moving to VERIFIED
Comment 12 Lukas Svaty 2013-12-17 05:40:47 EST
*is27, sorry typo
Comment 13 errata-xmlrpc 2014-01-21 11:19:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.