Bug 1025822 - PRD35 - [RFE] Provide a noreboot flag for RHEV-Tools
PRD35 - [RFE] Provide a noreboot flag for RHEV-Tools
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Windows Guest Tools (Show other bugs)
3.2.0
All Windows
high Severity high
: ---
: 3.5.0
Assigned To: Lev Veyde
Jiri Belka
integration
: FutureFeature
Depends On:
Blocks: rhev3.5beta 1156165
  Show dependency treegraph
 
Reported: 2013-11-01 12:48 EDT by Sadique Puthen
Modified: 2015-02-11 12:41 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this feature, a new command line option "ISNOREBOOT" was added to guest tools. When the option is used as part of a silent install (together with "ISSILENTMODE"), it disables the reboot of the machine at the end of the installation, allowing additional steps to be performed prior to rebooting the machine.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-11 12:41:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 6 Jiri Belka 2014-08-04 08:59:04 EDT
ok, 3.5.1 WGT (d/s).
Comment 7 Yaniv Lavi 2015-01-19 11:16:47 EST
Original request was:

1. What is the nature and description of the request?

Customer is developing an MS build server and they need to be able to do a quiet (i.e. don't reboot afterwards) install of RHEV-Tools.  What flags can we pass the RHEV Tools installer to achieve this?

We need to do this as part of a WDS deployment.  When the RHEV Tools installer completes, it reboots the VM causing all additional software to not install and the build to fail.

I fully understand the need for the reboot to occur and under 'normal' circumstances, I'd agree, but here Red Hat needs to give us a choice of when the reboot occurs.

2. Why does the customer need this? (List the business requirements here)

We need to do RHEV-tools installation as part of a WDS deployment.  When the RHEV Tools installer completes, it reboots the VM causing all additional software to not install and the build to fail. So we not block the reboot by RHEV-Tools and perform the reboot after all additional softwares are installed.

3. How would the customer like to achieve this? (List the functional requirements here)

By providing a no-reboot option when the exe is invoked.
Comment 9 errata-xmlrpc 2015-02-11 12:41:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0198.html

Note You need to log in before you can comment on or make changes to this bug.