This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1025829 - sysprep floppy is not attached to Windows 2008 R2 machine - even when specifically checked in Run Once
sysprep floppy is not attached to Windows 2008 R2 machine - even when specifi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
urgent Severity high
: ---
: 3.3.0
Assigned To: Roy Golan
Ilanit Stein
virt
: Regression
Depends On:
Blocks: 1027349 3.3rc1
  Show dependency treegraph
 
Reported: 2013-11-01 13:09 EDT by David Jaša
Modified: 2014-01-21 17:30 EST (History)
13 users (show)

See Also:
Fixed In Version: is27
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21261 None None None Never
oVirt gerrit 22138 None None None Never
oVirt gerrit 22290 None None None Never

  None (edit)
Description David Jaša 2013-11-01 13:09:16 EDT
Description of problem:
sysprep floppy is not attached to Windows 2008 R2 machine - even when specifically checked in Run Once

Version-Release number of selected component (if applicable):
is20.2:
rhevm-backend-3.3.0-0.30.beta1.el6ev.noarch

How reproducible:
always

Steps to Reproduce:
1. create vm with windows 2008 R2 os type, "Run Once" it with [sysprep] floppy checked
2. check if VM has floppy attached
3.

Actual results:
floppy is not attached to VM at all (vdsm doesn't get floppy in the device list of createVm command so unsuprisingly libvirt XML contains just hard & cdrom disks)

Expected results:
floppy is generated & attached

Additional info:
my VMs are created from template
Comment 2 David Jaša 2013-11-01 14:13:46 EDT
Note: when I change the OS type of the very same VM to e.g. Windows 7 x64, the floppy is attached just fine...
Comment 5 Michal Skrivanek 2013-11-12 07:40:41 EST
trivial typo in packaging/setup/plugins/ovirt-engine-setup/config/options.py for W2k8r2 sysprep file location
Comment 6 Sandro Bonazzola 2013-11-14 08:55:47 EST
merged upstream on master and 3.3 branch
Comment 7 Ilanit Stein 2013-11-21 10:06:00 EST
Is this fix included in is24.1?

Checked on is24.1: Failed QA:

1. Create a new VM, select Windows 2008 R2 x64 OS, runOnce with floppy:[sysprep]
On vdsm.log, VM device list didn't contain the floppy.

2. Create a new VM, select Windows XP OS, runOnce with floppy:[sysprep]

On vdsm.log, this VM device list contained the floppy:

               <disk device="floppy" snapshot="no" type="file">
                        <source file="/var/run/vdsm/payload/fa126bd8-8e33-42b1-8c4f-62419b05be9c.c12189a70f6714c9c761e15fc52bb56f.img" startupPolicy="optional"/>
                        <target bus="fdc" dev="fda"/>
                        <readonly/>
                        <serial/>
                        <readonly/>
                </disk>
Comment 9 Ilanit Stein 2013-11-24 01:42:57 EST
Bug moved to assigned since it failed QA (comment #7).
Comment 10 Michal Skrivanek 2013-12-04 04:20:08 EST
did you run engine-setup with a clean DB? 
do you see /etc/ovirt-engine/sysprep/sysprep.2k8 file on the engine host?
can you check the VdcOptions value of SysPrep2K8R2Path for a typo?
Comment 11 David Jaša 2013-12-04 09:36:42 EST
(In reply to Michal Skrivanek from comment #10)
> did you run engine-setup with a clean DB? 

the engine was installed at around is19 time, it's updated ever since.

> do you see /etc/ovirt-engine/sysprep/sysprep.2k8 file on the engine host?

yes

> can you check the VdcOptions value of SysPrep2K8R2Path for a typo?

# engine-config -a | grep SysPrep2K8R2Path
SysPrep2K8R2Path: /etc/ovirt-engine/gs4ysprep/sysprep.2k8 version: general

But even after I fixed it and restarted the engine, my 2008 R2 VMs just don't get their sysprep floppies....
Comment 12 Michal Skrivanek 2013-12-06 06:41:14 EST
Roy, it should be sysprep.2k8x64, the files are deployed as sysprep.2k8x86. And the comment should be fixed for R2 in osinfo file as well

The VdcOptions are not used anymore, so the whole section in patch 21261 should be removed. The file needs to be renamed directly in source tree packaging/etc/sysprep/
Comment 15 Ilanit Stein 2013-12-16 04:13:41 EST
Verified on is27:

Create a new VM, select Windows 2008 R2 x64 OS, runOnce with floppy:[sysprep]
On vdsm.log, VM device list contain the floppy:

<disk device="floppy" snapshot="no" type="file">
			<source file="/var/run/vdsm/payload/72345e72-9d85-48e4-b202-e15c7e0061d5.d6c90b7ad310136c04125524e1b69216.img" startupPolicy="optional"/>
			<target bus="fdc" dev="fda"/>
			<readonly/>
			<serial/>
			<readonly/>
		</disk>
Comment 16 Itamar Heim 2014-01-21 17:27:13 EST
Closing - RHEV 3.3 Released
Comment 17 Itamar Heim 2014-01-21 17:27:39 EST
Closing - RHEV 3.3 Released
Comment 18 Itamar Heim 2014-01-21 17:30:24 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.