Bug 1025841 - Unable to filter packets by VLAN tag
Unable to filter packets by VLAN tag
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libpcap (Show other bugs)
6.4
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Michal Sekletar
Tomas Dolezal
:
Depends On:
Blocks: 1070830 1159820
  Show dependency treegraph
 
Reported: 2013-11-01 13:41 EDT by Norman Elton
Modified: 2015-07-22 02:17 EDT (History)
3 users (show)

See Also:
Fixed In Version: libpcap-1.4.0-4.20130826git2dbcaa1.el6
Doc Type: Bug Fix
Doc Text:
Documentation for this issue is the same as for #1063328 Previously, running the "tcpdump" command with the filter expressioncontaining the keyword "vlan" produced unexpected output, as the filtergenerated by the libpcap Berkeley Packet Filter (BPF) compiler did notemploy BPF extensions. To fix this bug, libpcap has been amended and nowgenerates filters that use BPF extensions when appropriate. As a result,running "tcpdump" with filters containing "vlan" produces correct results.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-22 02:17:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Norman Elton 2013-11-01 13:41:39 EDT
Tcpdump drops all packets when filtering by VLAN tag. Works fine when reading packets from a file, but not when reading from a NIC.

For example, this captures nothing:

tcpdump -i eth15 -nnte vlan

But this works as expected:

tcpdump -i eth15 -nnte -w - | tcpdump -r - vlan

Kernel information:

# uname -a
Linux blocto.safety.net.wm.edu 2.6.32-358.23.2.el6.x86_64 #1 SMP Sat Sep 14 05:32:37 EDT 2013 x86_64 x86_64 x86_64 GNU/Linux

Tcpdump information:

# rpm -q tcpdump
tcpdump-4.0.0-3.20090921gitdf3cb4.2.el6.x86_64

Driver information:

# ethtool -i eth15
driver: e1000e
version: 2.1.4-k
firmware-version: 5.10-2
bus-info: 0000:26:00.1
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: no
Comment 2 Michal Sekletar 2013-11-08 04:10:07 EST
This is not a bug in tcpdump itself but rather in libpcap. Reassigning there. Note that before doing something about this on libpcap side, some changes in kernel has to be introduced.
Comment 3 Michal Sekletar 2014-02-06 09:30:30 EST
Just an quick update on the current status. Kernel part is done, now we can move to fixing libpcap.
Comment 4 Michal Sekletar 2014-11-04 07:36:51 EST
Opened a pull request on github trying to address this.

https://github.com/the-tcpdump-group/libpcap/pull/391

Feel free to join the discussion on github and also testing would be much appreciated. Thanks.
Comment 9 errata-xmlrpc 2015-07-22 02:17:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1288.html

Note You need to log in before you can comment on or make changes to this bug.