Bug 1025881 - clvmd -R fails - "EOF reading CLVMD" [NEEDINFO]
clvmd -R fails - "EOF reading CLVMD"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2-cluster (Show other bugs)
5.10
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Petr Rockai
Cluster QE
: Regression, TestBlocker
Depends On:
Blocks: 1049888
  Show dependency treegraph
 
Reported: 2013-11-01 15:42 EDT by Corey Marthaler
Modified: 2014-09-15 20:24 EDT (History)
15 users (show)

See Also:
Fixed In Version: lvm2-cluster-2.02.88-10.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-15 20:24:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mjuricek: needinfo? (snagar)


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2013-11-01 15:42:29 EDT
Description of problem:
[root@taft-01 ~]# clvmd -h
Usage: clvmd [options]
   -V       Show version of clvmd
   -h       Show this help information
   -d[n]    Set debug logging (0:none, 1:stderr (implies -f option), 2:syslog)
   -f       Don't fork, run in the foreground
   -R       Tell all running clvmds in the cluster to reload their device cache


[root@taft-01 ~]# cman_tool services
type             level name     id       state       
fence            0     default  00010001 none        
[1 2 4]
dlm              1     clvmd    00010004 none        
[1 2 4]


[root@taft-01 ~]# vgs
  VG             #PV #LV #SN Attr   VSize   VFree  
  VolGroup00       1   2   0 wz--n-  68.12G      0 
  helter_skelter   7   0   0 wz--nc 949.65G 949.65G


[root@taft-01 ~]# clvmd -R
EOF reading CLVMD[root@taft-01 ~]# 


[root@taft-01 ~]# strace clvmd -R
[...]
connect(3, {sa_family=AF_FILE, path="/var/run/setrans/.setrans-unix"...}, 110) = 0
sendmsg(3, {msg_name(0)=NULL, msg_iov(5)=[{"\1\0\0\0", 4}, {"\1\0\0\0", 4}, {"\1\0\0\0", 4}, {"\0", 1}, {"\0", 1}], msg_controllen=0, msg_flags=0}, MSG_NOSIGNAL) = 14
readv(3, [{"\1\0\0\0", 4}, {"\1\0\0\0", 4}, {"\0\0\0\0", 4}], 3) = 12
readv(3, [{"\0", 1}], 1)                = 1
close(3)                                = 0
getuid()                                = 0
geteuid()                               = 0
socket(PF_FILE, SOCK_STREAM, 0)         = 3
connect(3, {sa_family=AF_FILE, path="/var/run/lvm/clvmd.sock"...}, 110) = 0
write(3, "(\0\0\0\0\0\0\0\0\0\0\0\377\377\377\377\0", 17) = 17
read(3, "", 18)                         = 0
write(2, "EOF reading CLVMD", 17EOF reading CLVMD)       = 17
exit_group(1)                           = ?



Version-Release number of selected component (if applicable):
2.6.18-371.el5

lvm2-2.02.88-12.el5    BUILT: Tue Jun 25 07:01:44 CDT 2013
lvm2-cluster-2.02.88-9.el5_10.1    BUILT: Mon Oct 21 04:20:44 CDT 2013
device-mapper-event-1.02.67-2.el5    BUILT: Mon Oct 17 08:31:56 CDT 2011
cmirror-1.1.39-15.el5    BUILT: Thu Apr 26 17:07:01 CDT 2012
kmod-cmirror-0.1.22-3.el5    BUILT: Tue Dec 22 13:39:47 CST 2009


How reproducible:
Everytime
Comment 1 Petr Rockai 2013-11-06 14:02:55 EST
Is this a regression (maybe related to 25bed9968155f43ef0b8832383ef711e7ae1685d)? Also, I assume that lvm can talk to clvmd as usual... (what I find suspicious is that we have a regression test for clvmd -R, so we should have noticed if it broke). I'll have a closer look.
Comment 6 Petr Rockai 2014-01-14 07:44:58 EST
The problem is, as far as I can tell, that f5d39ec97aed3a77b5d0dfcd954dd78547e5748d needs to be backported to the RHEL5 package of 2.02.88  -- presumably 63b8ed7c37d166efd6f7e24bad8f64a2bc3239ef went in but that breaks clvmd -R without f5d39ec... in exactly the manner seen on 5.10.z packages.
Comment 11 Nenad Peric 2014-04-07 07:37:23 EDT
Marking VERIFIED based on Comment 9 and test with lvm2-2.02.88-12.el5 as well

[root@virt-066 ~]# clvmd -R
[root@virt-066 ~]# rpm -q lvm2
lvm2-2.02.88-12.el5
Comment 17 errata-xmlrpc 2014-09-15 20:24:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1219.html

Note You need to log in before you can comment on or make changes to this bug.