Bug 1025900 - deadlock in SwitchYard project meta-data loading
deadlock in SwitchYard project meta-data loading
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: SwitchYard Editor (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER7
: 6.0.0
Assigned To: Rob Cernich
Andrej Podhradsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 17:47 EDT by Rob Cernich
Modified: 2014-06-16 19:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:26:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SWITCHYARD-1804 Critical Closed deadlock in SwitchYard project meta-data loading 2014-06-16 19:48:10 EDT

  None (edit)
Description Rob Cernich 2013-11-01 17:47:27 EDT
If the workspace builder is executing and the SwitchYard project meta-data has not been loaded, a deadlock can occur. It appears the condition occurs primarily during workspace startup if a file in a SwitchYard project is open for editing and "link with editor" is enabled. The SwitchYard navigator extension tries to load meta-data, but can't acquire the workspace lock. In the mean time, the builder can't load the meta-data because the navigator extension holds the lock for the SwitchYardProject.
Comment 1 JBoss JIRA Server 2013-11-01 19:31:56 EDT
Rob Cernich <rcernich@redhat.com> made a comment on jira SWITCHYARD-1804

also fixes an npe found during testing (only occurs if the output switchyard.xml fiile is empty).
Comment 2 JBoss JIRA Server 2013-11-04 11:44:35 EST
Keith Babo <kbabo@redhat.com> made a comment on jira SWITCHYARD-1804

pushed
Comment 3 Andrej Podhradsky 2013-12-18 12:29:39 EST
Verified with JBDS-IS 7.0.0.CR1
Comment 4 JBoss JIRA Server 2014-06-16 19:48:13 EDT
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1804 to Closed

Note You need to log in before you can comment on or make changes to this bug.