Bug 1025903 - RPM file path includes directory names from upstream
RPM file path includes directory names from upstream
Status: CLOSED DUPLICATE of bug 1093745
Product: Pulp
Classification: Community
Component: rpm-support (Show other bugs)
Master
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: pulp-bugs
pulp-qe-list
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 17:54 EDT by Michael Hrivnak
Modified: 2014-09-22 20:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-22 20:17:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Hrivnak 2013-11-01 17:54:28 EDT
Description of problem:
When pulp saves an RPM to disk, it saves the relative path as it appears in the repo's metadata. This is harmless, but it would be better to strip any leading directories off the path as it appears in the XML. Currently, the same RPM could be saved on disk twice if it appears in two different directories within two different repos.

Version-Release number of selected component (if applicable):
2.3

How reproducible:
always

Steps to Reproduce:
1. sync a repository that puts RPMs in a directory like "Packages"
2. look in /var/lib/pulp/content/rpm/path/to/an/rpm

Actual results:
the directory tree ends in "Packages" or whatever the directory name is from step 

Expected results:
the directory tree should not include the "Packages" directory
Comment 1 Chris Duryee 2014-09-22 20:17:20 EDT
I believe this was fixed as part of #1093745. If that is not the case, feel free to re-open.

*** This bug has been marked as a duplicate of bug 1093745 ***

Note You need to log in before you can comment on or make changes to this bug.