This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1025908 - unable to unlock LUKS encrypted device from Live-Desktop
unable to unlock LUKS encrypted device from Live-Desktop
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: gnome-disk-utility (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luis Bazan
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 18:39 EDT by Chris Murphy
Modified: 2013-12-31 17:34 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-31 17:34:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Murphy 2013-11-01 18:39:28 EDT
Description of problem:


Version-Release number of selected component (if applicable):
Fedora-Live-Desktop-x86_64-20-Beta-TC6.iso
gnome-disk-utility-3.10.0-1.fc20.x86_64


How reproducible:
Always

Steps to Reproduce:
0. qemu/kvm boot Live Desktop with a qcow2 device attached that contains a default Fedora 19 installation via Guided partitioning with encryption checked.
1. Launch Disks.
2. Click on the encrypted partition, click unlock button.
3. Enter passphrase to unlock appears; I try to enter password but there is no text or bullets entered. 

Actual results:
Unable to unlock the disk, even meticulously typing the password in the blind.

Error unlocking encrypted device
Error unlocking /dev/vdb2: Command-line 'cryptsetup luksOpen "/dev/vdb2" "luks-<uuid>"' exited with a non-zero exit status 1: (udisks-error-quark, 0)


Expected results:
I should be able to unlock the disk from live media.

Additional info:
Comment 1 Fedora Blocker Bugs Application 2013-11-01 18:43:10 EDT
Proposed as a Blocker for 20-final by Fedora user chrismurphy using the blocker tracking app because:

 "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use."
Comment 2 Chris Murphy 2013-11-01 18:57:19 EDT
cryptsetup luksOpen works. After cryptsetup luksClose and relaunching gnome-disk-utility, it now unlocks this partition.

Reboot, go straight to gnome-disk-utility, it works! It's a Heisenbug!
Comment 3 Adam Williamson 2013-11-13 13:51:50 EST
Discussed at 2013-11-13 blocker review meeting - http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-13/f20-final-blocker-review-1.2013-11-13-17.01.log.txt . Agreed to delay determination while we attempt to reproduce it. Chris, can you try again with Beta? Others will test this too, thanks to kparal.
Comment 4 Martin Krizek 2013-11-14 05:52:06 EST
I can't reproduce it with Beta (RC5). I tried it 5 times and unlocking worked each time.
Comment 5 Mike Ruckman 2013-11-14 12:18:53 EST
Discussed in 2013-11-14 Blocker Review Meeting [1]. Voted as a RejectedBlocker because currently this seems to be very hard to hit, and is therefore rejected as a blocker. Please re-propose if you find a reliable reproducer.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-14/
Comment 6 Chris Murphy 2013-11-18 15:04:56 EST
I now think this is a different bug, where VNC keyboard input simply doesn't work until I click on another application window and then back to TigerVNC's window. This probably should be closed unless it can be reproduced other than with VNC.

Note You need to log in before you can comment on or make changes to this bug.