Bug 1025927 - 32-bit install installs kernel instead of kernel-PAE
32-bit install installs kernel instead of kernel-PAE
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 22:20 EDT by Andre Robatino
Modified: 2013-11-04 12:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-02 09:01:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2013-11-01 22:20:26 EDT
Description of problem:
Doing a minimal text install from the 20 Beta RC2 i386 DVD, kernel rather than kernel-PAE is installed, even though both are on the media. I checked that this also happens on 20 Beta TC6. Have not determined yet how far back it goes.

Version-Release number of selected component (if applicable):
anaconda-20.25.5-1

How reproducible:
always
Comment 1 Andre Robatino 2013-11-01 23:44:19 EDT
Doing 32-bit minimal text installs first from the 20 Alpha RC4 (Gold) and then the 20 Alpha TC1 DVD, the problem goes all the way back to 20 Alpha TC1. It did not happen with 19 Final.
Comment 2 satellitgo 2013-11-02 03:17:30 EDT
Testing:
1-) Fedora-20-Beta-i386-netinst.iso burned to CD:
GUI Install from CD to USB HD on i7 system 76 Netbook (x86_64) yields a PAE Kernel

2-)VirtualBox 32 bit VM  GUI install with Fedora-20-Beta-i386-netinst.iso:
GUI install yielded non PAE Kernel.
Comment 3 Andre Robatino 2013-11-02 09:01:46 EDT
My previous testing was with VirtualBox-4.3 (now updated to 4.3.2, but shows the same behavior). Doing a minimal text install of 20 Beta RC2 in KVM, I get kernel-PAE. So the problem is apparently limited to VirtualBox (and possibly introduced in the recent major 4.3 update, otherwise someone would probably have noticed before now). I'll file a bug with them. Sorry for the noise.
Comment 4 Andre Robatino 2013-11-04 09:12:46 EST
For anyone else who stumbles across this, you need to check the "Enable PAE/NX" box under System/Processor in the guest, in order for the guest to have PAE support. See

https://forums.virtualbox.org/viewtopic.php?f=3&t=58302
Comment 5 satellitgo 2013-11-04 12:07:43 EST
If you do this VirtualBox gives :fail whale" on boot and does not run.
Windows 8.1 Virtualbox 32 bit Yoga2 Pro
 lvn pipes?

Note You need to log in before you can comment on or make changes to this bug.