This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1025946 - cannot add samba printer without python-smbc
cannot add samba printer without python-smbc
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1145739
  Show dependency treegraph
 
Reported: 2013-11-02 07:41 EDT by Jozef Mlich
Modified: 2015-08-02 19:58 EDT (History)
5 users (show)

See Also:
Fixed In Version: system-config-printer-1.4.4-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1145739 (view as bug list)
Environment:
Last Closed: 2014-03-30 02:03:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jozef Mlich 2013-11-02 07:41:12 EDT
Description of problem:
system-config-printer cannot add new printer from samba network without python-smbc

$ system-config-printer

** (system-config-printer.py:13193): WARNING **: Can't load fallback CSS resource: Failed to import: The resource at '/org/gnome/adwaita/gtk-fallback.css' does not exist

** (system-config-printer.py:13193): WARNING **: Can't load fallback CSS resource: Failed to import: The resource at '/org/gnome/adwaita/gtk-fallback.css' does not exist
Caught non-fatal exception.  Traceback:
File "/usr/share/system-config-printer/newprinter.py", line 2531, in on_btnSMBVerify_clicked
    ctx = pysmb.smbc.Context (debug=debug, auth_fn=do_auth)
NameError: global name 'pysmb' is not defined
Continuing anyway..



Actual results:
no error message printer is just inaccessible


Expected results:
I should see error message: "You are stupid user, you have to install python-smbc before you try to add samba printer"


Additional info:
Comment 1 Tim Waugh 2013-11-04 06:25:39 EST
Inaccessible? The Verify button won't work, but surely Forward works fine?
Comment 2 Jozef Mlich 2013-11-04 09:08:31 EST
I apologize for misleading description of problem. I don't know whether forward button works. I didn't even tried it, because password was "wrong".

In case the python-smbc is not installed, the user enters correct password, its verification fails. At the end the users ask administrator of network printer for help. 

The problem is, the system-config-printer should distinguish whether the password is incorrect, or the necessary package is missing. 

The expected behaviour is to show correct error message. The error message should lead to installation of package instead of printer password change. But not in the opposite case, when the package is installed and functional.

In case of need of additional information, please run "yum remove python-smbc" command.
Comment 3 Tim Waugh 2013-11-18 07:55:35 EST
I think the upstream system-config-printer commit 1dffd4a is the final bit of the fix for this.
https://git.fedorahosted.org/cgit/system-config-printer.git/commit/?id=1dffd4a
Comment 4 Fedora Update System 2014-03-17 05:10:50 EDT
system-config-printer-1.4.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/system-config-printer-1.4.4-1.fc20
Comment 5 Fedora Update System 2014-03-18 04:14:54 EDT
Package system-config-printer-1.4.4-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.4.4-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-4014/system-config-printer-1.4.4-1.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-03-30 02:03:19 EDT
system-config-printer-1.4.4-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 markusN 2014-10-27 11:23:37 EDT
I still get this error (using XFCE):

[root@pgis_north ]# system-config-printer 
Error creating proxy: The connection is closed (g-io-error-quark, 18)
Error creating proxy: The connection is closed (g-io-error-quark, 18)
Error creating proxy: The connection is closed (g-io-error-quark, 18)
Error creating proxy: The connection is closed (g-io-error-quark, 18)
Error creating proxy: The connection is closed (g-io-error-quark, 18)
Caught non-fatal exception.  Traceback:
File "/usr/share/system-config-printer/newprinter.py", line 2528, in on_btnSMBVerify_clicked
    ctx = pysmb.smbc.Context (debug=debug, auth_fn=do_auth)
NameError: global name 'pysmb' is not defined
Continuing anyway..
Caught non-fatal exception.  Traceback:
File "/usr/share/system-config-printer/newprinter.py", line 2528, in on_btnSMBVerify_clicked
    ctx = pysmb.smbc.Context (debug=debug, auth_fn=do_auth)
NameError: global name 'pysmb' is not defined
Continuing anyway..
Caught non-fatal exception.  Traceback:
File "/usr/share/system-config-printer/newprinter.py", line 2528, in on_btnSMBVerify_clicked
    ctx = pysmb.smbc.Context (debug=debug, auth_fn=do_auth)
NameError: global name 'pysmb' is not defined
Continuing anyway..
[root@pgis_north ]

[neteler@pgis_north tmp]$ uname -a
Linux pgis_north 3.16.6-200.fc20.x86_64 #1 SMP Wed Oct 15 13:06:51 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

[neteler@pgis_north tmp]$ rpm -qa | grep system-config-printer
system-config-printer-udev-1.4.6-1.fc20.x86_64
system-config-printer-1.4.6-1.fc20.x86_64
system-config-printer-libs-1.4.6-1.fc20.noarch
Comment 8 Tim Waugh 2014-10-27 11:41:18 EDT
Basically the 'Verify' button shouldn't be sensitive when python-smbc isn't installed. That fix went in last week, a few days after the 1.4.6 release:

https://git.fedorahosted.org/cgit/system-config-printer.git/commit/?h=1.4.x&id=8adca607c6f76d7304667a2ffa16b0b628530d38

Note You need to log in before you can comment on or make changes to this bug.