Bug 1025956 - Dist-geo-rep : 'stime' xattr is not the minimum of all distribute subvolumes
Dist-geo-rep : 'stime' xattr is not the minimum of all distribute subvolumes
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
Vijaykumar Koppad
: ZStream
Depends On: 1025955
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-02 09:20 EDT by Venky Shankar
Modified: 2014-08-24 20:50 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.39rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1025955
Environment:
Last Closed: 2013-11-27 10:45:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Venky Shankar 2013-11-02 09:20:18 EDT
+++ This bug was initially created as a clone of Bug #1025955 +++

Description of problem:
'stime' xattr is not fetched as the minimum of all distribute subvolumes. This is required by geo-replication for correctly identify the slave lag.


Version-Release number of selected component (if applicable):
mainline

How reproducible:
always
Comment 3 Gowrishankar Rajaiyan 2013-11-11 05:31:02 EST
Please provide steps to verify.
Comment 4 Venky Shankar 2013-11-11 06:03:17 EST
Steps to verify:

1. Create and start a distributed volume and mount the volume
2. Perform some I/O on the mount
3. Check the 'stime' extended-attribute for the brick (on the backend)
4. From the mount fetch the extended attribute (name to be taken from step 3)
5. The value of the xattr should be the minimum value on the bricks.
Comment 5 Vijaykumar Koppad 2013-11-15 05:30:19 EST
Verified on the build glusterfs-3.4.0.44rhs

on the mount point 

[root@shaktiman ~]# getfattr -d -m . -e hex /mnt/master/
getfattr: Removing leading '/' from absolute path names
# file: mnt/master/
trusted.glusterfs.b2a5d205-79ec-471e-a72f-782a2063c683.c261bc11-9898-4e49-83e8-758c494a82e9.stime=0x5285f40b00065b94
trusted.glusterfs.b2a5d205-79ec-471e-a72f-782a2063c683.xtime=0x5285f40b000c343f
trusted.glusterfs.volume-id=0xb2a5d20579ec471ea72f782a2063c683

and the value of stime from the backends, 

>>> int("5285f40b00065b94",16)
5946427211094842260
>>> int("5285f40c0003a98a",16)
5946427215389632906
>>> int("5285f40b00065b94",16)
5946427211094842260
>>> int("5285f40b00065b94",16)
5946427211094842260
>>> min(5946427211094842260,5946427215389632906,5946427211094842260,5946427211094842260)
5946427211094842260

and 5285f40b00065b94 is the minimum stime, which got on mount point.
Comment 6 errata-xmlrpc 2013-11-27 10:45:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.