Bug 1025963 - yumdownloader --resolve overzealous with dependencies
yumdownloader --resolve overzealous with dependencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-02 09:38 EDT by Gene Czarcinski
Modified: 2013-11-11 04:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 04:54:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
with any --resolve (1.95 KB, text/plain)
2013-11-05 16:15 EST, Gene Czarcinski
no flags Details
yumdownloader -v --resolve rpm rpm-libs ... (61.04 KB, text/plain)
2013-11-05 16:20 EST, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2013-11-02 09:38:41 EDT
Description of problem:
yumdownloader is way overzealous with dependencies.  For example, ifyou enter:
      yumdownloader  --resolve  rpm rpm-libs rpm-build-libs rpm-python
will result in some 40+ packages which includes *** gcc *** ... are you serious!?!?

Version-Release number of selected component (if applicable):
yum-utils-1.1.31-18.fc19.noarch

How reproducible
yes

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Zdeněk Pavlas 2013-11-04 02:58:43 EST
That might be wrong, as I don't see any obvious gcc dependency. Could you run yumdownloader with '-v' and attach the output, so we see what exactly requires gcc?  Thanks!
Comment 2 Gene Czarcinski 2013-11-05 16:15:28 EST
Created attachment 820015 [details]
with any --resolve
Comment 3 Gene Czarcinski 2013-11-05 16:20:36 EST
Created attachment 820016 [details]
yumdownloader -v --resolve rpm rpm-libs ...

OK, I am running on a x86_64 system (surprise) and only hace x86_64 packages installed.  So, what got sucked in were all of the extras i686 packages needed when the rpm*i686 packages were downloaded.  I did not want any i686 packages.  I tried to limit what happened by specifying --archlist=x86_64 but that had no effect and I thought that it should have.
Comment 4 Zdeněk Pavlas 2013-11-06 04:26:18 EST
I see the problem. "yumdownloader --resolve foo" works behind the scene much like "yum --downloadonly install foo".  You asked for "rpm-build-libs", without specifying the architecture. Since there are both x86_64 and i686 arches available, and x86_64 is already installed, it tries to use i686.

I assume this is the expected behavior:
https://bugzilla.redhat.com/show_bug.cgi?id=182348

You probably don't want to download rpm-build-libs.i686 and all it's deps, so just specify the arch with "yumdownloader --resolve rpm-build-libs.x86_64".
Comment 5 Gene Czarcinski 2013-11-07 12:48:46 EST
OK, now I understand.  I had tried --archlist=x86_64 with no effect.  This information should be added to the man-page.
Comment 6 Zdeněk Pavlas 2013-11-11 04:54:46 EST
Closing, as the described behavior is intended.

Note You need to log in before you can comment on or make changes to this bug.