Bug 1025967 - RFE: dist-geo-rep: use tar+ssh as an option for data synchronization
RFE: dist-geo-rep: use tar+ssh as an option for data synchronization
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Venky Shankar
M S Vishwanath Bhat
: FutureFeature, ZStream
Depends On: 1025966
Blocks: 1023124
  Show dependency treegraph
 
Reported: 2013-11-02 10:40 EDT by Venky Shankar
Modified: 2016-05-31 21:56 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.42rhs
Doc Type: Enhancement
Doc Text:
With this enhancement update,a new option has been added to the geo-replication feature of Red Hat storage which enables to choose 'tar over ssh' as a sync engine.Executing "gluster volume geo-replication <master> <slave-host>::<slave> config use-tarssh true' triggers this option.
Story Points: ---
Clone Of: 1025966
Environment:
Last Closed: 2013-11-27 10:46:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Venky Shankar 2013-11-02 10:40:11 EDT
+++ This bug was initially created as a clone of Bug #1025966 +++

Description of problem:
tar+ssh as a data synchronization engine (optional; rsync is the default)

Version-Release number of selected component (if applicable):
mainline
Comment 2 M S Vishwanath Bhat 2013-11-08 05:45:21 EST
This option is not working.

Tested with Version: glusterfs-3.4.0.39rhs-1.el6rhs.x86_64 

I created 2 million files each of which are 500KB and even after 1 day and 20+ hours only 5000+ files are synced. Rest are not being synced.
Comment 3 M S Vishwanath Bhat 2013-11-11 11:21:42 EST
We have couple of bugs with this option and they are being tracked by different buzilla bugs. So moving this bug to verified.

Now there is an option to sync the files through tar+ssh instead of rsync which used by default.
Comment 5 errata-xmlrpc 2013-11-27 10:46:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.