Bug 1025985 - OpenDNSSEC signer cannot be started due to a typo in service file
OpenDNSSEC signer cannot be started due to a typo in service file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: opendnssec (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Wouters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-02 14:55 EDT by Jan Včelák
Modified: 2014-01-19 22:04 EST (History)
2 users (show)

See Also:
Fixed In Version: opendnssec-1.4.3-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-19 22:04:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (729 bytes, patch)
2013-11-02 14:56 EDT, Jan Včelák
no flags Details | Diff

  None (edit)
Description Jan Včelák 2013-11-02 14:55:51 EDT
Description of problem:

There is a typo in ods-signerd.service file causing the service to fail starting.


Version-Release number of selected component (if applicable):
opendnssec-1.4.2-1.fc19.x86_64


How reproducible:
always

Steps to Reproduce:
1. systemctl start ods-signerd
2. systemctl status ods-signerd
3.

Actual results:
ods-signerd.service - OpenDNSSEC signer daemon
   Loaded: loaded (/usr/lib/systemd/system/ods-signerd.service; disabled)
   Active: failed (Result: exit-code) since Sat 2013-11-02 19:53:52 CET; 48s ago
  Process: 3981 ExecStart=/usr/sbin/ods-signerd -d ODS_SIGNERD_OPT (code=exited, status=2)

Nov 02 19:53:52 fedora systemd[1]: Started OpenDNSSEC signer daemon.
Nov 02 19:53:52 fedora systemd[1]: ods-signerd.service: main process exited, code=exited, status=2/INVALIDARGUMENT
Nov 02 19:53:52 fedora systemd[1]: Unit ods-signerd.service entered failed state.


Expected results:
ods-signerd daemon to start


Additional info:
Comment 1 Jan Včelák 2013-11-02 14:56:42 EDT
Created attachment 818612 [details]
patch

Attaching patch fixing the typo.
Comment 2 Fedora Update System 2014-01-09 22:44:16 EST
opendnssec-1.4.3-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/opendnssec-1.4.3-1.fc20
Comment 3 Fedora Update System 2014-01-11 03:46:22 EST
Package opendnssec-1.4.3-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing opendnssec-1.4.3-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0649/opendnssec-1.4.3-1.fc20
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2014-01-19 22:04:55 EST
opendnssec-1.4.3-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.