Bug 10260 - fconfigure -mode doesn't work on serial port
Summary: fconfigure -mode doesn't work on serial port
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcltk   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-20 11:28 UTC by mbertani
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-20 13:41:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mbertani 2000-03-20 11:28:28 UTC
I run this script from tclsh:

------------------------
set comPort "/dev/ttyS0"
set comId [open $comPort r+]
if {$comId == ""} {
	bgerror "Can't open $comPort"
	return -1
}

fconfigure $comId \
	-translation binary \
	-blocking 0 \
	-buffering none \
	-mode 115200,n,8,1

after 10000
close $comId
-------------------------

while the program is waiting in "after 10000" , through another shell I call

 stty -a -F /dev/ttyS0

and I see a completely different setting (the _real_ one!).

To solve the problem it was necessary to rebuild Tcl/Tk from Scriptics sources tar.gz
(8.3b2, the newest at this time).
In order to understand if the problem was a Tcl bug, I rebuilt also 8.0.5 sources, but
the behaviour is equal - it works.

Please note that I had the same problem also with previous versions (5.0) of RH linux.

Best Regards
Massimo Bertani

Comment 1 Jeff Johnson 2000-03-20 13:41:59 UTC
The problem appears to be with the build of tcltk-8.0.5, which probably
was built against a glibc version that incorrectly defined higher baud
rates (I assume from reading your reported behavior).

Try tcltk-8.2.3-36 packages from Raw Hide, they have been built against
more recent glibc headers. (Note: tcltk cannot be upgraded to 8.3 until
all the components (e.g. tclx, itcl, expect, and tix have been ported to 8.3).


Note You need to log in before you can comment on or make changes to this bug.