Bug 102604 - ifup-aliases does not handle correctly linuxconf-generated aliases. (wrong version of initscripts ?)
Summary: ifup-aliases does not handle correctly linuxconf-generated aliases. (wrong ve...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-18 16:00 UTC by Fabio Lopiano
Modified: 2014-03-17 02:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-18 16:31:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fabio Lopiano 2003-08-18 16:00:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
/etc/sysconfig/network-script/ifup-aliases yelds an error like this:

error in ifcfg-lo:0: didn't specify device or ipaddr

when reading an alias generated by linuxconf.

the problem should have been resolved in initscripts-6.67-1 (according to CVS)
but, apparently, the initscripts-6.67-1.rpm was built from initscripts-6.67.

In fact I checked initscripts-6.67-1.src.rpm and it contains the scripts from 6.67.

So it seems that the "bug" is actually due to an error in the building of the rpm.


Version-Release number of selected component (if applicable):
initscripts-6.67-1

How reproducible:
Always

Steps to Reproduce:
create an alias for an interface via linuxconf (e.g. lo:0) 
restart network (or just call ifup l0)


    

Actual Results:  error in ifcfg-lo:0: didn't specify device or ipaddr

Additional info:

I wrote enough information on the description, I guess.

Comment 1 Bill Nottingham 2003-08-18 16:31:52 UTC
At this point, if it's not fixed in current sources, it probably won't be fixed.
It appears to be fixed in 6.75 and later.


Note You need to log in before you can comment on or make changes to this bug.