Bug 1026072 - Dist-geo-rep : After node reboot, all the changelog files in .processed dir of geo-rep working directory will be deleted
Dist-geo-rep : After node reboot, all the changelog files in .processed dir o...
Status: CLOSED DUPLICATE of bug 1095314
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Venky Shankar
storage-qa-internal@redhat.com
:
Depends On:
Blocks: 1020127
  Show dependency treegraph
 
Reported: 2013-11-03 06:46 EST by Vijaykumar Koppad
Modified: 2015-07-28 06:35 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-24 04:13:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2013-11-03 06:46:06 EST
Description of problem:After node reboot, all the files in .processed dir of geo-rep  working directory will be cleared.  


Version-Release number of selected component (if applicable):
glusterfs-3.4.0.38rhs

How reproducible:Happens everytime. 


Steps to Reproduce:
1.Create and start a geo-rep relationship between master(dist-rep) and slave
2.create some data on master and let it sync to slave. 
3.Bring down a node ( active or passive) 
4.create some data on master and let it sync. 
5.bring back the node. 
4.check the files in .processed dir of geo-rep working dir. 

Actual results: It deletes  all the changelog files from .processed dir.


Expected results: It shouldn't delete any of the changelog files form processed. 


Additional info:
Comment 2 Venky Shankar 2013-11-14 05:53:22 EST
possibly /var being temporary?

Amar, any alternative for $working_dir in geo-replication?
Comment 3 Pavithra 2013-11-25 03:49:13 EST
After a discussion with Amar, this bug was decided to be documented as a known issue in the Big Bend Update 1 Release Notes. Here is the link:

http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Storage/2.1/html/2.1_Update_1_Release_Notes/chap-Documentation-2.1_Update_1_Release_Notes-Known_Issues.html
Comment 5 Aravinda VK 2014-12-24 04:13:10 EST

*** This bug has been marked as a duplicate of bug 1095314 ***

Note You need to log in before you can comment on or make changes to this bug.