Bug 1026089 - Setup - When installing report without DWH installed it doesn't check DWH status.
Setup - When installing report without DWH installed it doesn't check DWH sta...
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Alex Lourie
Barak Dagan
integration
: Triaged
Depends On:
Blocks: 3.3snap2
  Show dependency treegraph
 
Reported: 2013-11-03 10:28 EST by Yaniv Lavi (Dary)
Modified: 2013-12-18 21:39 EST (History)
8 users (show)

See Also:
Fixed In Version: IS23 - rhevm-reports-3.3.0-20.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
This new implementation requires the Manager and DWH to be run and set up correctly before the reports package can be set up. If the settings for the Manager or DWH are not found, the reports setup will exit with a corresponding message. The database configuration is now defined in a spec file.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-14 08:19:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21144 None None None Never
oVirt gerrit 21145 None None None Never

  None (edit)
Description Yaniv Lavi (Dary) 2013-11-03 10:28:53 EST
Description of problem:
When installing report without DWH installed it doesn't check DWH status. This causes setup to fail and no message instructing the user to install dwh first.

Version-Release number of selected component (if applicable):
3.3.0

How reproducible:
Always

Steps to Reproduce:
1. install rhevm-report rpm
2. install engine
3. run rhevm-reports setup

Actual results:
stops with exception 

Expected results:
should dispaly message telling use to install dwh first

Additional info:
Comment 1 Alex Lourie 2013-11-11 06:14:56 EST
Please reproduce with last build.
Comment 3 Shai Revivo 2013-11-14 08:19:05 EST
his bug was fixed and is slated to be in the upcoming version. As we are focusing our testing at this phase on severe bugs, this bug was closed without going through its verification step
Comment 4 Charlie 2013-11-27 19:49:06 EST
This bug is currently attached to errata RHEA-2013:15115. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.