Bug 102609 - rpm can't install i386 or i686 RPM files
rpm can't install i386 or i686 RPM files
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks: 97942
  Show dependency treegraph
 
Reported: 2003-08-18 12:49 EDT by Albert Fluegel
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-20 11:13:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albert Fluegel 2003-08-18 12:49:14 EDT
Description of problem:
On ia64 the rpm command dumps core, if one tries to install an RPM
that has been packaged on a i386 or i686 architecture. Packaging
identically the same stuff on an ia64 rpm works again. In my opinion
installing an i386 should work as it does work also on x86_64 and
the processor/Redhat-taroon-Beta with the 32-Bit Compatibility-Stuff
installed can execute it and btw also noarch packages can't be
installed either.


Version-Release number of selected component (if applicable): rpm-4.2.1-0.29


How reproducible:
Install an RPM from the i386 distribution, that is not present
on an ia64 box

Steps to Reproduce:
1. rpm -i /path/to/package-x.y-i386.rpm
2.
3.
    
Actual results:
segfault

Expected results:
package becomes installed like on x86_64

Additional info:
Comment 1 Jeff Johnson 2003-08-20 11:13:53 EDT
Yup. Fixed in rpm-4.2.1-0.31.
Comment 2 Eric Hagberg 2003-09-08 11:54:29 EDT
is this fixed?

I still get rpm crashing on a system I've got here that was upgraded through
up2date a number of times. Unfortunately, the coredump isn't very informative:

(gdb) bt
#0  0x20000000005b4b10 in strcmp () from /lib/tls/libc.so.6.1

And if I "--force --nodeps" the installation seems to complete, but fails to
actually create the files (symlinks are all created) in the /emul tree.
Comment 3 Eric Hagberg 2003-09-09 11:54:35 EDT
Looks like there's also an important file, not owned by any rpm, which is
required to get some i386/i686 rpms installed properly on an ia64 system...
/etc/rpm/macros, which contains:

%_transaction_color	3

Strange that something so important wouldn't be owned by an rpm:

[root@saias34 ia64]# rpm -qf /etc/rpm/macros
file /etc/rpm/macros is not owned by any package

Note You need to log in before you can comment on or make changes to this bug.