Bug 1026091 - Setup - Failure on missing file.
Setup - Failure on missing file.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity high
: ---
: 3.3.0
Assigned To: Itamar Heim
Barak Dagan
integration
: Triaged
Depends On:
Blocks: 3.3snap2
  Show dependency treegraph
 
Reported: 2013-11-03 10:32 EST by Yaniv Lavi
Modified: 2014-01-21 09:56 EST (History)
6 users (show)

See Also:
Fixed In Version: IS22 - rhevm-reports-3.3.0-18.el6ev.noarch.rpm
Doc Type: Enhancement
Doc Text:
rhevm-reports now validates existing configuration files, to prevent the installation from failing due to missing configuration files.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 09:56:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20834 None None None Never

  None (edit)
Description Yaniv Lavi 2013-11-03 10:32:09 EST
Description of problem:
engine.conf is not present in latest build and reports setup fails on this.

Version-Release number of selected component (if applicable):
3.3.0

How reproducible:
Always

Steps to Reproduce:
1. install engine IS21
2. install reports+dwh

Actual results:
fails on missing config file

Expected results:
should not fail.

Additional info:
Comment 2 Yaniv Lavi 2013-11-06 03:13:06 EST
*** Bug 1027116 has been marked as a duplicate of this bug. ***
Comment 3 Barak Dagan 2013-11-18 08:50:56 EST
Verified in IS23, rhevm-reports-3.3.0-20.el6ev.noarch:

ls /etc/ovirt-engine/engine.conf
ls: cannot access /etc/ovirt-engine/engine.conf: No such file or directory

# rhevm-reports-setup -a 33.local.reports.answerfile
Welcome to ovirt-engine-reports setup utility
Editing XML files...                                  [ DONE ]
Setting DB connectivity...                            [ DONE ]
Deploying Server...                                   [ DONE ]
Updating Redirect Servlet...                          [ DONE ]
Importing reports...                                  [ DONE ]
Customizing Server...                                 [ DONE ]
Running post setup steps...                           [ DONE ]
Starting ovirt-engine...                              [ DONE ]
Restarting httpd...                                   [ DONE ]
Succesfully installed ovirt-engine-reports.
The installation log file is available at: /var/log/ovirt-engine/ovirt-engine-reports-setup-2013_11_18_18_26_40.log
Comment 4 Charlie 2013-11-27 19:49:29 EST
This bug is currently attached to errata RHEA-2013:15115. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 7 errata-xmlrpc 2014-01-21 09:56:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0035.html

Note You need to log in before you can comment on or make changes to this bug.