Bug 1026156 - [ALL_LANG] Unlocalized error message shown when unable to associate an IP address to the port
[ALL_LANG] Unlocalized error message shown when unable to associate an IP add...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
4.0
Unspecified Unspecified
high Severity unspecified
: ---
: 11.0 (Ocata)
Assigned To: Jason E. Rist
Shai Revivo
: i18n, Triaged
Depends On: 1086247
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-03 23:49 EST by Yuko Katabami
Modified: 2016-10-20 07:37 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-20 07:37:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unlocalized error message - unable to associate IP address to a port (146.58 KB, image/png)
2013-11-12 17:32 EST, Yuko Katabami
no flags Details
Unlocalised "External network unreachable" string (27.24 KB, image/png)
2014-10-07 10:30 EDT, Julie Pichon
no flags Details
Unlocalized error message in Japanese environment of OSP-8 Beta (117.65 KB, image/png)
2016-04-21 07:53 EDT, Yuko Katabami
no flags Details

  None (edit)
Description Yuko Katabami 2013-11-03 23:49:43 EST
Description of problem:
Unlocalized error message is shown when it is unable to associate an IP address to the port

Version-Release number of selected component (if applicable): 4.0


How reproducible: 100%


Steps to Reproduce:
1. Log in to Dashboard with admin account
2. Click "Settings" to change the language to Japanese
3. Select Project => Access & Security => Floating IP
4. With a given IP address listed, click "Associate" button. 
5. In "Port to be associated", select a port which cannot be associated with the IP.

Actual results:
Unlocalized error message is displayed.

Expected results:
It should be localizd.


Additional info:
Screenshot attached.
Comment 1 Yuko Katabami 2013-11-03 23:50:32 EST
Confirmed that this string is not included in the upstream translation file.
Comment 3 Julie Pichon 2013-11-12 10:13:48 EST
Thank you for the bug report.

Horizon is displaying the error message as it is returned by the Neutron networking service. There are two issues at hand here: Neutron strings are not translated, and there is no good system currently to request for a message to be returned in a specific locale. Fixing this will require a larger effort together with the other projects (cf bug 1026113).
Comment 4 Yuko Katabami 2013-11-12 17:32:45 EST
Created attachment 823157 [details]
Unlocalized error message - unable to associate IP address to a port

I forgot to attach this screenshot when I filed this bug.
Comment 5 Julie Pichon 2014-10-07 10:28:46 EDT
I can confirm this still happens in Juno / 6.0. (The English message has been a bit improved at least, see screenshot.) The message is stored in Neutron.

It looks like Neutron has added partial support for supporting language headers: https://blueprints.launchpad.net/neutron/+spec/user-locale-api . It's not quite clear to me from the blueprint description what is still missing, but hopefully it should be resolved by the same Horizon blueprint that will be created for bug 1026113.

Because this is feature-level work and upstream is closed for new features in Juno, I am moving the target to future / 7.0. However if it turns out the work is reasonably backportable to 6.0, I'll move the target back. I doubt it'll happen in time before the initial release though.

(The fact that 2 error messages are displayed is a separate issue, tracked upstream at https://bugs.launchpad.net/horizon/+bug/1301374 )
Comment 6 Julie Pichon 2014-10-07 10:30:44 EDT
Created attachment 944614 [details]
Unlocalised "External network unreachable" string

Additional, for a quick way to reproduce that particular error message:

1. Create a new network, with a subnet
2. Launch a new instance using that network
3. Go to the Access and Security / Floating IPs tab and try to add a Floating IP to that instance
Comment 13 Itxaka 2016-04-15 07:15:05 EDT
Seems that the bp upstream has been marked as obsolete. So Im not sure what can we do from the horizon side if the error messages are always returned on english no matter what :(
Comment 14 Yuko Katabami 2016-04-16 01:53:43 EDT
Hi Itxaka,

Thank you very much for the update.

In the upstream translation system [1], I can see this message has been translated into Japanese in Sep 2015.

Does it mean the translation will be used in Horizon in the future, or it will not be shown as it is programmed to be so?


[1] https://translate.openstack.org/webtrans/Application.seam?project=neutron&iteration=stable-mitaka&localeId=ja&locale=en#view:doc;projectsearch:therefore;projectsearchin:both;doc:neutron;search:therefore
Comment 16 Itxaka 2016-04-20 07:45:07 EDT
Yuko, it looks like its translated, and the appropriate patch for querying neutron in a local language is merged (https://review.openstack.org/#/c/39590/) so it looks like it should return the error in the proper language.

Checking the horizon requests done to neutron, I can see that they all include the Accepted language so at a first glance, it seem that even with the BP obsolete, neutron should return the errors in the local language (if there is a translation for that error)
Comment 22 Yuko Katabami 2016-04-21 07:53 EDT
Created attachment 1149434 [details]
Unlocalized error message in Japanese environment of OSP-8 Beta
Comment 30 Jason E. Rist 2016-10-18 11:46:22 EDT
Seems to be blocked by https://bugzilla.redhat.com/show_bug.cgi?id=1086247, adding as 'Depends On:'
Comment 31 Radomir Dopieralski 2016-10-20 07:36:37 EDT
The root cause was fixed in https://bugzilla.redhat.com/show_bug.cgi?id=1086247

Note You need to log in before you can comment on or make changes to this bug.