Bug 102618 - Logitech Wheelmouse does not work
Logitech Wheelmouse does not work
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-mouse (Show other bugs)
8.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-18 16:08 EDT by Javier P
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-28 17:10:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Javier P 2003-08-18 16:08:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425

Description of problem:
I have problems making my KVM (Lynksys KVM2kit), my motherboard (PCCHIPS
M785LMRE) and my mouse (Logitech M-C48) behaving properly together.

Right now they work fine as long as I do not try to use the wheelmouse. I have
had to settle for PS/2 Protocol.

If I try to set it up as IMPS/2, all signals go haywire. Just moving the mouse
(not clicking anything) works as if I were cutting and pasting info if I am in
text mode (GPM)

If I am in graphics mode, the mouse goes to the left, bottom corner and tries to
stay there. If i move it to the right, top, it goes along until halfway through
it will jump back to the left, bottom corner. also, just moving the mouse will
work as if I were clicking icons around.

Funny thing is that I have the same exact setup with my other computer that has
a Biostar MV6VLR motherboard and the mouse/KVM/motherboard work fine. The
computer with PCCHIPS motherboard used to work fine before when it also had a
Biostar MV6VLR motherboard. 

If I take the KVM out of the loop, them Protocol IMPS/2 works fine on the
PCCHIPS motherboard.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install PCCHIPS M785LMR motherboard with Logitech M-C48 mouse
2. Install RedHat Linux 8.0
3. Select Generic PS/2 wheelmouse in graphics mode
4. Reboot
5.a In graphics mode, try to move the mouse, all above will happen
5.b In text mode, try to move the mouse
    

Actual Results:  above explanation

Expected Results:  normal mouse operation

Additional info:
Comment 1 Javier P 2003-08-20 05:01:24 EDT
How much different is the PS/2 from the IMPS/2 interface. Why does the PS/2 
work with the KVM, but the IMPS/2 does not?
Comment 2 Brent Fox 2003-08-28 17:10:52 EDT
The problem is that KVMs are not all the same.  I have two Belkin KVMs.  They
are essentially the same model but they are a few years apart in age.  One works
perfectly but the other one has the same haywire problem that you are seeing.

I've talked to the XFree86 guys about this and they say that many KVMs have
different ways of passing on the mouse signals and the specs are not published.
 For this reason, KVMs are not officially supported.  

Unfortunately, there's nothing I can do from the config tool end to fix the
problem.  

What I do is use the KVM to switch only the monitor and keyboard.  I have two
mice which are plugged directly into the machines.  This works ok in a 2
computer setup, but it doesn't really scale beyond that.  :(

Note You need to log in before you can comment on or make changes to this bug.