Bug 102619 - KeepAlive setting in Apache httpd.conf is wrong
Summary: KeepAlive setting in Apache httpd.conf is wrong
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: httpd (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL: http://httpd.apache.org/docs-2.0/mod/...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-18 20:10 UTC by Chris Merrill
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-20 13:01:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Merrill 2003-08-18 20:10:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529

Description of problem:
After a new installation of RH9, the KeepAlive setting in the httpd.conf file says:

#
# KeepAlive: Whether or not to allow persistent connections (more than
# one request per connection). Set to "Off" to deactivate.
#
KeepAlive false

The documentation clearly states that should be 'On' or 'Off', in both the
config file and the Apache docs.

Also, please consider changing the default to "On" since this gives
significantly better performance.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RH9
    

Actual Results:  Config file uses 'false' for the KeepAlive setting.

Expected Results:  The KeepAlive setting should be 'On' or 'Off', with the
Apache default being 'On'.

Additional info:

Comment 1 Joe Orton 2003-08-20 13:01:34 UTC
The default config in RHL9 has:

"KeepAlive Off"

I'm not sure where you got "false" from.  It's off by default deliberately;
enabling keepalive can tie up server children which can actually hurt
performance on high-volume sites.


Comment 2 Chris Merrill 2003-08-20 13:18:50 UTC
I got it from a fresh RH9 installation.  I was wondering if somebody else had
changed it, so I checked my server at home (which nobody else has access to) and
it was 'false' on that one, as well.  It was also a fresh RH9 installation.  

Maybe my ISOs are old and the problem has already been fixed.


Note You need to log in before you can comment on or make changes to this bug.