Bug 1026193 - The command "rhc app show --gears /port-forword/tail $app "could NOT trigger client message about quota warning.
The command "rhc app show --gears /port-forword/tail $app "could NOT trigger...
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Fabiano Franz
libra bugs
: UpcomingRelease
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 02:14 EST by Qiushui Zhang
Modified: 2015-06-11 17:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-11 17:42:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qiushui Zhang 2013-11-04 02:14:46 EST
Description of problem:
Add files to an application, so that more than 90% quota is used. Do "rhc app show $appname --gears". There is no quota warning message.

Version-Release number of selected component (if applicable):
STG(devenv_stage_549)
devenv_3984
rhc 1.16.9

How reproducible:
always

Steps to Reproduce:
1. Create an application
rhc app create rb ruby-1.9
2. Create files to occupy the space. On the gear,
dd if=/dev/zero of=~/app-root/data/testfile bs=1M count=950
3. Do "rhc app show rb --gears"

Actual results:
No quota warning message is shown

Expected results:
There should be quota warning message like "Warning gear 52773c8e2587c8470500006c is using 93.0% of disk quota"

Additional info:
"rhc port-forward rb -g 52773c8e2587c8470500006c" will NOT trigger the warning message, too. Even no quota warning logs are added to "/var/log/ruby193-mcollective.log"
Comment 1 XiuJuan Wang 2013-11-11 04:11:55 EST
devenv_4016
rhc 1.17.2
'rhc port-forward $app'  and 'rhc tail $app' are also no quota warning message
Comment 2 Fabiano Franz 2013-11-12 15:09:47 EST
This is related to commands that use ssh to perform.
Comment 4 Fabiano Franz 2014-01-27 23:17:31 EST
Work in progress here: https://github.com/fabianofranz/rhc/tree/bugs/1026193

Requires a review of other commands too. There seems to be other commands that should warn about quota usage but are not. Tagging UpcomingRelease but will merge to stage if possible.
Comment 5 Fabiano Franz 2014-01-28 13:53:06 EST
Commands that need to check quota (not doing it right now):

show-app
deployments | list-deployment
show-deployment
activate-deployment
port-forward
tail
show-cartridge
status-cartridge
git-clone
save-snapshot
restore-snapshot

Note You need to log in before you can comment on or make changes to this bug.