Bug 1026197 - [ja_JP] Unnecessary counter suffix is included in Japanese translation of "Used xx out of yy"
[ja_JP] Unnecessary counter suffix is included in Japanese translation of "Us...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
4.0
Unspecified Unspecified
medium Severity unspecified
: z1
: 4.0
Assigned To: Yuko Katabami
Lijun Li
: Translation, Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 02:48 EST by Mie Yamamoto
Modified: 2016-04-26 10:11 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.2.1-1.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 09:22:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hypervisor - xx out of xxxx (156.40 KB, image/png)
2013-11-04 02:48 EST, Mie Yamamoto
no flags Details
Hypervisor - xx out of xxxx 1 (172.77 KB, image/png)
2013-11-04 02:48 EST, Mie Yamamoto
no flags Details
Japanese translation on Manage Compute Overview screen (161.19 KB, image/png)
2013-11-04 20:00 EST, Yuko Katabami
no flags Details
xxx out of xxxxx (18.38 KB, image/png)
2014-01-15 19:35 EST, Mie Yamamoto
no flags Details
xx out of xxx under manage compute (18.38 KB, image/png)
2014-01-15 19:37 EST, Mie Yamamoto
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 60713 None None None Never

  None (edit)
Description Mie Yamamoto 2013-11-04 02:48:15 EST
Created attachment 818954 [details]
Hypervisor - xx out of xxxx

Description of problem: 
メモリ使用量
7GB 個中 1GB 個使用中 
ディスク使用量
9.0GB 個中 1.0GB 個使用中 


Version-Release number of selected component (if applicable): 4.0


How reproducible: 100%


Steps to Reproduce:
1. Click on Admin-System Panel-Hypervisors tab from the left side panel,
2. 
3.

Actual results:
メモリ使用量
7GB 個中 1GB 個使用中 
ディスク使用量
9.0GB 個中 1.0GB 個使用中 

Expected results:

個 is not needed within the phrase "個使用中" for memory usage and disk usage 
because the unit (MB/GB) is already provided

Additional info:
Comment 1 Mie Yamamoto 2013-11-04 02:48:45 EST
Created attachment 818955 [details]
Hypervisor - xx out of xxxx 1
Comment 3 Yuko Katabami 2013-11-04 17:13:45 EST
Upstream source/target:

#: dashboards/admin/hypervisors/templates/hypervisors/index.html:16
#: dashboards/admin/hypervisors/templates/hypervisors/index.html:23
#: dashboards/admin/hypervisors/templates/hypervisors/index.html:30
#, python-format
msgid "Used <span> %(used)s </span> of <span> %(available)s </span>"
msgstr "<span> %(available)s </span> 個中 <span> %(used)s </span> 個使用中"

This translation works with CPU, however it does not work with memory or disk usage.

We will propose the upstream ja-JP user group to remove the counter suffix from the translation.
Comment 4 Yuko Katabami 2013-11-04 19:58:21 EST
This is also applicable to Project => Manage Compute => Overview.
Screenshot attached.

I found another issue. When the upper limit (or quota) is not set, it shows the value "inf" - assuming that it is standing for "infinity", however it may not be clear enough for the users when incorporated into Japanese translation.
Comment 5 Yuko Katabami 2013-11-04 20:00:08 EST
Created attachment 819429 [details]
Japanese translation on Manage Compute Overview screen
Comment 6 Yuko Katabami 2013-11-10 16:00:29 EST
Reported to the upstream ja-JP user group on 8 Nov and is currently under discussion.
Comment 7 Julie Pichon 2013-11-12 10:05:00 EST
Thanks, please update the bug report when the translation file has been updated with the correct translation.

I don't believe the 'inf' is translatable at the moment, could you file a separate bug for this?
Comment 8 Yuko Katabami 2013-11-12 20:18:32 EST
(In reply to Julie Pichon from comment #7)
> Thanks, please update the bug report when the translation file has been
> updated with the correct translation.
> 
> I don't believe the 'inf' is translatable at the moment, could you file a
> separate bug for this?

Hi Julie, 

I have filed a separate bug for "inf" in "Used <span> %(used)s </span> of <span> %(available)s </span>": BZ#1029719
Comment 9 Yuko Katabami 2013-12-11 17:57:13 EST
This translation fix has been merged into the upstream Havana Stable Update.
Moving the status to POST.
Comment 11 Mie Yamamoto 2014-01-15 19:35:17 EST
Created attachment 850753 [details]
xxx out of xxxxx
Comment 12 Mie Yamamoto 2014-01-15 19:37:31 EST
Created attachment 850754 [details]
xx out of xxx under manage compute
Comment 13 Mie Yamamoto 2014-01-15 19:38:37 EST
Verified on the latest RHOS 4.0.z puddle. Screenshot attached
Comment 16 Lon Hohberger 2014-02-04 12:19:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-0046.html

Note You need to log in before you can comment on or make changes to this bug.