Bug 1026203 - Missing crypt() NULL checks in pam modules
Missing crypt() NULL checks in pam modules
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pam (Show other bugs)
6.5
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Tomas Mraz
Dalibor Pospíšil
:
: 1009976 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 03:11 EST by Qiao Zhao
Modified: 2014-10-14 04:09 EDT (History)
5 users (show)

See Also:
Fixed In Version: pam-1.1.1-18.el6
Doc Type: Bug Fix
Doc Text:
no doc text needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 04:09:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
core file (748.00 KB, application/x-core)
2013-11-04 03:11 EST, Qiao Zhao
no flags Details

  None (edit)
Description Qiao Zhao 2013-11-04 03:11:16 EST
Created attachment 818956 [details]
core file

Description of problem:
Occur Segmentation faule (core dumped) when I change passwd on my kvm guest

Version-Release number of selected component (if applicable):
kernel: 2.6.32-425.el6.x86_64
glibc: glibc-2.12-1.129.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Update kernel to 2.6.32-425.el6.x86_64
2. change root passwd # passwd
3.

Actual results:
[root@localhost ~]# passwd 
Changing password for user root.
New password: 
BAD PASSWORD: it is based on a dictionary word
BAD PASSWORD: is too simple
Retype new password: 
Segmentation fault (core dumped)

# dmesg
passwd[11228]: segfault at 0 ip 00007eac0b5fe7c4 sp 00007fff842e76f8 error 4 in libc-2.12.so[7eac0b57c000+18a000]

Expected results:
No segmentation fault

Additional info:
Comment 13 Tomas Mraz 2014-06-19 09:22:09 EDT
*** Bug 1009976 has been marked as a duplicate of this bug. ***
Comment 16 errata-xmlrpc 2014-10-14 04:09:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1579.html

Note You need to log in before you can comment on or make changes to this bug.