Bug 1026208 - a race condition in Java Thread callbacks
a race condition in Java Thread callbacks
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt-java-connector (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:1535fa342fdb6fa0e5c2684287c...
:
: 1048507 (view as bug list)
Depends On:
Blocks: 1051483
  Show dependency treegraph
 
Reported: 2013-11-04 03:23 EST by Paweł Sikora
Modified: 2016-11-30 19:45 EST (History)
9 users (show)

See Also:
Fixed In Version: abrt-java-connector-1.0.7-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1051483 (view as bug list)
Environment:
Last Closed: 2014-01-21 00:54:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (16.24 KB, text/plain)
2013-11-04 03:23 EST, Paweł Sikora
no flags Details
File: cgroup (159 bytes, text/plain)
2013-11-04 03:23 EST, Paweł Sikora
no flags Details
File: core_backtrace (301.12 KB, text/plain)
2013-11-04 03:23 EST, Paweł Sikora
no flags Details
File: dso_list (4.83 KB, text/plain)
2013-11-04 03:23 EST, Paweł Sikora
no flags Details
File: environ (3.97 KB, text/plain)
2013-11-04 03:23 EST, Paweł Sikora
no flags Details
File: hs_err.log (89.15 KB, text/plain)
2013-11-04 03:24 EST, Paweł Sikora
no flags Details
File: limits (1.29 KB, text/plain)
2013-11-04 03:24 EST, Paweł Sikora
no flags Details
File: maps (44.17 KB, text/plain)
2013-11-04 03:24 EST, Paweł Sikora
no flags Details
File: open_fds (3.72 KB, text/plain)
2013-11-04 03:24 EST, Paweł Sikora
no flags Details
File: proc_pid_status (940 bytes, text/plain)
2013-11-04 03:24 EST, Paweł Sikora
no flags Details
File: var_log_messages (591 bytes, text/plain)
2013-11-04 03:24 EST, Paweł Sikora
no flags Details

  None (edit)
Description Paweł Sikora 2013-11-04 03:23:20 EST
Description of problem:
probably the underlying Freenet daemon causes the abort. no other java applications running.

Version-Release number of selected component:
java-1.7.0-openjdk-headless-1.7.0.60-2.4.3.0.fc20

Additional info:
reporter:       libreport-2.1.9
backtrace_rating: 4
cmdline:        java -agentpath:/usr/lib64/libabrt-java-connector.so=abrt=on -Dnetworkaddress.cache.ttl=0 -Dnetworkaddress.cache.negative.ttl=0 -Djava.net.preferIPv4Stack=true -Xms60m -Xmx512m -Djava.library.path=lib -classpath wrapper.jar:bcprov-jdk15on-149.jar:freenet-ext.jar:freenet.jar -Dwrapper.key=tThySw_6z8OdxlfE -Dwrapper.backend=pipe -Dwrapper.disable_console_input=TRUE -Dwrapper.pid=18702 -Dwrapper.version=3.5.20 -Dwrapper.native_library=wrapper -Dwrapper.arch=x86 -Dwrapper.ignore_signals=TRUE -Dwrapper.service=TRUE -Dwrapper.cpu.timeout=10 -Dwrapper.jvmid=2 freenet.node.NodeStarter freenet.ini
crash_function: os::abort
executable:     /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.60-2.4.3.0.fc20.x86_64/jre-abrt/bin/java
kernel:         3.11.6-301.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 0 (8 frames)
 #2 os::abort at /usr/src/debug/java-1.7.0-openjdk-1.7.0.60-2.4.3.0.fc20.x86_64/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:1594
 #3 VMError::report_and_die at /usr/src/debug/java-1.7.0-openjdk-1.7.0.60-2.4.3.0.fc20.x86_64/openjdk/hotspot/src/share/vm/utilities/vmError.cpp:1053
 #4 JVM_handle_linux_signal at /usr/src/debug/java-1.7.0-openjdk-1.7.0.60-2.4.3.0.fc20.x86_64/openjdk/hotspot/src/os_cpu/linux_x86/vm/os_linux_x86.cpp:531
 #6 jthread_map_push at /usr/src/debug/abrt-java-connector-befb850dbc72b117ad6bebabee314e7d41b97183/src/jthread_map.c:110
 #7 callback_on_thread_start at /usr/src/debug/abrt-java-connector-befb850dbc72b117ad6bebabee314e7d41b97183/src/abrt-checker.c:1056
 #8 JvmtiExport::post_thread_start at /usr/src/debug/java-1.7.0-openjdk-1.7.0.60-2.4.3.0.fc20.x86_64/openjdk/hotspot/src/share/vm/prims/jvmtiExport.cpp:1024
 #9 JavaThread::run at /usr/src/debug/java-1.7.0-openjdk-1.7.0.60-2.4.3.0.fc20.x86_64/openjdk/hotspot/src/share/vm/runtime/thread.cpp:1649
 #10 java_start at /usr/src/debug/java-1.7.0-openjdk-1.7.0.60-2.4.3.0.fc20.x86_64/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:892

Potential duplicate: bug 853621
Comment 1 Paweł Sikora 2013-11-04 03:23:32 EST
Created attachment 818978 [details]
File: backtrace
Comment 2 Paweł Sikora 2013-11-04 03:23:35 EST
Created attachment 818979 [details]
File: cgroup
Comment 3 Paweł Sikora 2013-11-04 03:23:47 EST
Created attachment 818980 [details]
File: core_backtrace
Comment 4 Paweł Sikora 2013-11-04 03:23:52 EST
Created attachment 818981 [details]
File: dso_list
Comment 5 Paweł Sikora 2013-11-04 03:23:56 EST
Created attachment 818982 [details]
File: environ
Comment 6 Paweł Sikora 2013-11-04 03:24:01 EST
Created attachment 818983 [details]
File: hs_err.log
Comment 7 Paweł Sikora 2013-11-04 03:24:05 EST
Created attachment 818984 [details]
File: limits
Comment 8 Paweł Sikora 2013-11-04 03:24:10 EST
Created attachment 818985 [details]
File: maps
Comment 9 Paweł Sikora 2013-11-04 03:24:21 EST
Created attachment 818986 [details]
File: open_fds
Comment 10 Paweł Sikora 2013-11-04 03:24:26 EST
Created attachment 818987 [details]
File: proc_pid_status
Comment 11 Paweł Sikora 2013-11-04 03:24:30 EST
Created attachment 818988 [details]
File: var_log_messages
Comment 12 Jakub Filak 2013-11-05 08:09:42 EST
A pull request which fixes this bug report has been created.

https://github.com/jfilak/abrt-java-connector/pull/23
Comment 13 Jakub Filak 2013-11-05 08:23:16 EST
Upstream commit f295d8f3ac744cb61223c854bd155eb4f92e0866 fixes this bug report.
Comment 14 Jakub Filak 2014-01-10 17:58:16 EST
*** Bug 1048507 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2014-01-10 18:33:16 EST
abrt-java-connector-1.0.7-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/abrt-java-connector-1.0.7-1.fc20
Comment 16 Fedora Update System 2014-01-12 00:01:52 EST
Package abrt-java-connector-1.0.7-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-java-connector-1.0.7-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0688/abrt-java-connector-1.0.7-1.fc20
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2014-01-21 00:54:08 EST
abrt-java-connector-1.0.7-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.