This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1026221 - With optimistic TX, conditional commands may wrongly succeed
With optimistic TX, conditional commands may wrongly succeed
Status: CLOSED DUPLICATE of bug 1024373
Product: JBoss Data Grid 6
Classification: JBoss
Component: Infinispan (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Tristan Tarrant
Martin Gencur
:
Depends On:
Blocks: 1017190
  Show dependency treegraph
 
Reported: 2013-11-04 03:49 EST by Radim Vansa
Modified: 2013-11-04 16:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 05:14:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker ISPN-3677 Critical Closed With optimistic TX, conditional commands may wrongly succeed 2015-05-04 06:48:33 EDT

  None (edit)
Description Radim Vansa 2013-11-04 03:49:15 EST
Situation with optimistic TX, originator = entry's primary owner:

1. The conditional check suceeds when the command is executed
2. In TxDistributionInterceptor, ignorePreviousValue is set to true
3. The command is then enlisted in the modifications list with the ignorePreviousValue set to true
4. During the prepare/commit phase the command ignores the condition

Result:
Two commands, replace(key, A, B), replace(key, A, C) may both overwrite the entry (and the one committed later wins, actually overwriting B instead of A).
Comment 2 JBoss JIRA Server 2013-11-04 05:12:28 EST
Radim Vansa <rvansa@redhat.com> updated the status of jira ISPN-3677 to Closed
Comment 3 JBoss JIRA Server 2013-11-04 05:12:28 EST
Radim Vansa <rvansa@redhat.com> made a comment on jira ISPN-3677

Duplicate of ISPN-3655
Comment 4 Radim Vansa 2013-11-04 05:14:09 EST

*** This bug has been marked as a duplicate of bug 1024373 ***

Note You need to log in before you can comment on or make changes to this bug.