Bug 1026237 - [ALL_LANG] Unlocalized Popup Window in Network Topology Diagram
[ALL_LANG] Unlocalized Popup Window in Network Topology Diagram
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
4.0
Unspecified Unspecified
high Severity unspecified
: ga
: 10.0 (Newton)
Assigned To: Jason E. Rist
Ido Ovadia
: i18n, Triaged
Depends On:
Blocks: 1342445
  Show dependency treegraph
 
Reported: 2013-11-04 04:06 EST by Yuko Katabami
Modified: 2016-12-14 10:25 EST (History)
11 users (show)

See Also:
Fixed In Version: python-django-horizon-10.0.0-3.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1342445 (view as bug list)
Environment:
Last Closed: 2016-12-14 10:25:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unlocalized popup window (196.67 KB, image/png)
2013-11-04 04:06 EST, Yuko Katabami
no flags Details
Network topology popup - Icehouse / RHEL OSP 5.0 (12.38 KB, image/png)
2014-05-27 07:05 EDT, Julie Pichon
no flags Details
network topology popup localized (1) (27.18 KB, image/png)
2016-12-13 14:07 EST, Yuko Katabami
no flags Details
network topology popup localized (2) (27.05 KB, image/png)
2016-12-13 14:07 EST, Yuko Katabami
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1226159 None None None Never
Launchpad 1323599 None None None Never
Launchpad 1484113 None None None Never

  None (edit)
Description Yuko Katabami 2013-11-04 04:06:18 EST
Created attachment 819015 [details]
Unlocalized popup window

Description of problem:
Unlocalized popup windows that are shown when place mouse over an item in Network Topology Diagram

Version-Release number of selected component (if applicable): 4.0


How reproducible: 100%


Steps to Reproduce:
1. Log in to Dashboard with Admin account.
2. Click "Settings" menu and change the language other than English.
3. On the left panel, select Project => Network Topology
4. Place mouse over an item in the diagram

Actual results:
Popup window is not localized 

Expected results:
It should be localized

Additional info:
Screenshot attached.
Comment 2 Julie Pichon 2013-11-12 10:34:01 EST
Some of the topology view missing translations are partially resolved in https://bugs.launchpad.net/horizon/+bug/1226159 upstream.

For the pop-up itself, there are other issues related to translations in client-side templates that we don't have a good solution for yet, but hope to fix in 5.0 (cf. https://blueprints.launchpad.net/horizon/+spec/clientside-translation upstream).
Comment 3 Julie Pichon 2014-05-27 07:03:55 EDT
This has improved a little (cf. screenshot) but is not perfect yet. I'm moving the target to 6.0 to handle the rest and also filed https://bugs.launchpad.net/horizon/+bug/1323599 upstream to track the remaining items.
Comment 4 Julie Pichon 2014-05-27 07:05:06 EDT
Created attachment 899471 [details]
Network topology popup - Icehouse / RHEL OSP 5.0
Comment 7 Julie Pichon 2015-02-11 05:13:45 EST
This is slowly getting fixed, but it is taking time as there is no easy to do client-side i18n at the moment. There are patches to improve this upstream, but they are moving slowly.
Comment 12 Matthias Runge 2015-08-12 06:31:39 EDT
Just retested this, network topology is localized for me.

The term 'ACTIVE' still misses translation, the same applies for status of "SHUTOFF" (status comes from nova). It should be translatable though, at least status is translated, when looking at instances panel.
Comment 16 Itxaka 2016-02-11 04:15:11 EST
All patches upstream have been merged and ported up to kilo.
Downstream backport are done as well, not merged yet.
Comment 17 Itxaka 2016-02-18 08:51:03 EST
My last comment seems to be wrong.

This patch was merged in master upstream which resolved the last missing translations on the network topology page:
https://review.openstack.org/#/c/268087/

But its still awaiting the backport to Liberty:
https://review.openstack.org/#/c/269049/

When the upstream backport is done I will backport it to downstream 8.0
Comment 18 Itxaka 2016-03-29 05:40:59 EDT
All upstream patches have been merged so this fix should be available on the target release specified (9.0) when its released.
Comment 24 Jon Schlueter 2016-12-12 22:36:14 EST
Yuko might you be able to do a quick sanity verification on this bz using the publicly available RC bits?
Comment 25 Yuko Katabami 2016-12-12 22:43:08 EST
Hi Jon,

I am wondering if you can provide me a test environment, so that I can check.
My environment is a bit old (RHOSP 9), but you would like to check on the latest RC?

Kind regards,

Yuko
Comment 26 Yuko Katabami 2016-12-13 14:07 EST
Created attachment 1231315 [details]
network topology popup localized (1)
Comment 27 Yuko Katabami 2016-12-13 14:07 EST
Created attachment 1231316 [details]
network topology popup localized (2)
Comment 28 Yuko Katabami 2016-12-13 14:09:33 EST
Verified the fix on the RC build. (see attached screenshots)
Moving the status to VERIFIED.
Comment 30 errata-xmlrpc 2016-12-14 10:25:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html

Note You need to log in before you can comment on or make changes to this bug.