Bug 1026259 - no operations starts on agent installed via RPM
no operations starts on agent installed via RPM
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Agent (Show other bugs)
JON 3.2
x86_64 Linux
high Severity urgent
: ER06
: JON 3.2.0
Assigned To: Stefan Negrea
Mike Foley
:
Depends On:
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-11-04 04:46 EST by Armine Hovsepyan
Modified: 2015-09-02 20:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 08:04:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
agent_operations.png (574.37 KB, image/png)
2013-11-04 04:46 EST, Armine Hovsepyan
no flags Details

  None (edit)
Description Armine Hovsepyan 2013-11-04 04:46:00 EST
Created attachment 819037 [details]
agent_operations.png

Description of problem:
no operations starts on agent installed via RPM

Version-Release number of selected component (if applicable):
jon 3.2 er4

How reproducible:
always

Steps to Reproduce:
1. install jon 3.2 server on IP1
2. install jon 3.2 agent via rpm on IP2 (i've upgraded from 3.1.2 to 3.2)
3. schedule manual autodiscovery or any other operation on Agent or Platform resources for agent on IP2

Actual results:
no operations is started
The following message is being logged in agent.log endlessly:
INFO  [InventoryManager.availability-1] (rhq.core.pc.inventory.AvailabilityExecutor)- Scan Starting: Mon Nov 04 04:43:24 EST 2013
[InventoryManager.availability-1] (rhq.core.pc.inventory.AvailabilityExecutor)- Scan Ended   : Mon Nov 04 04:43:24 EST 2013 : Scan [startTime=1383558204927, endTime=1383558204928, runtime=1, isFull=false, isForced=false, numResources=192, numGetAvailabilityCalls=12, numScheduledRandomly=0, numPushedByInterval=11, numAvailabilityChanges=0, numDeferToParent=0]



Expected results:
schedules operations are started 

Additional info:
screen-shots attached
Comment 1 Armine Hovsepyan 2013-11-04 07:06:34 EST
Update: I am unable to reproduce the case with clean upgrade.
Comment 2 Mike Foley 2013-11-04 08:00:26 EST
JON 3.2 requirement is PKG-002 ...
Comment 3 Stefan Negrea 2013-11-05 18:11:28 EST
Can you please provide the agent logs for the installation that has issues? Also, were both the server and the agent upgraded from 3.1.2 to 3.2?

Can you please explain the difference between a clean upgrade (comment #2) and the steps followed on comment #1 ?
Comment 4 Armine Hovsepyan 2013-11-06 04:17:43 EST
I don't have the agent.log saved, the only message in log was the one in description.

The only difference between 1st and 2nd scenarios was time. Both upgrades were done on clean environment (clean db), but the issue was visible in 2-3 days after the upgrade. 

I am unable to reproduce the issue anymore to share more logs.
Comment 5 Stefan Negrea 2013-11-06 07:32:09 EST
So in the first case, the agent that got upgraded ran fine for a few days?
Comment 6 Stefan Negrea 2013-11-06 08:04:07 EST
Talked with Armine directly and the agent ran fine for a few days after the upgrade. So this problem is not related to the RPM or the RPM upgrade process. It can be a network glitch or a lost connection between the server and agent. But none of these can be confirmed without the logs. 

Closing because it cannot be reproduced and not related to the agent RPM.

Note You need to log in before you can comment on or make changes to this bug.