Bug 1026268 - Power outage prevents vms from turning back up
Power outage prevents vms from turning back up
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
3.3
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.3.2
Assigned To: Sergey Gotliv
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 05:01 EST by Ohad Basan
Modified: 2016-02-10 11:58 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 09:24:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ohad Basan 2013-11-04 05:01:46 EST
Description of problem:

I have an ovirt 3.3 setup with one host and two storage domains
had a power outage.
the setup restored successfully. meaning > dc up, host up and storages are up.
trying to start vm fails.
moved the host to maintenance and back to active and now vm start successfully.
Comment 1 Ohad Basan 2013-11-04 05:06:57 EST
Thread-6015::ERROR::2013-11-03 17:17:46,434::blockVolume::446::Storage.Volume::(validateImagePath) Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/blockVolume.py", line 444, in validateImagePath
    os.mkdir(imageDir, 0755)
OSError: [Errno 2] No such file or directory: '/rhev/data-center/3e0452c8-21b5-4df1-aced-44bc4c568229/eb317662-1dab-458b-b9dd-82634e6222ae/images/43cfaf08-c75c-4e03-a0c8-58d631fac864'
Thread-6015::ERROR::2013-11-03 17:17:46,435::task::850::TaskManager.Task::(_setError) Task=`3e67fbe2-8d9a-4daf-a765-afc49063e53b`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 857, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/logUtils.py", line 45, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/storage/hsm.py", line 3243, in prepareImage
    imgVolumes = img.prepare(sdUUID, imgUUID, volUUID)
  File "/usr/share/vdsm/storage/image.py", line 235, in prepare
    chain = self.getChain(sdUUID, imgUUID, volUUID)
  File "/usr/share/vdsm/storage/image.py", line 171, in getChain
    srcVol = volclass(self.repoPath, sdUUID, imgUUID, volUUID)
  File "/usr/share/vdsm/storage/blockVolume.py", line 86, in __init__
    volume.Volume.__init__(self, repoPath, sdUUID, imgUUID, volUUID)
  File "/usr/share/vdsm/storage/volume.py", line 140, in __init__
    self.validate()
  File "/usr/share/vdsm/storage/blockVolume.py", line 95, in validate
    volume.Volume.validate(self)
  File "/usr/share/vdsm/storage/volume.py", line 152, in validate
    self.validateImagePath()
  File "/usr/share/vdsm/storage/blockVolume.py", line 447, in validateImagePath
    raise se.ImagePathError(imageDir)
ImagePathError: Image path does not exist or cannot be accessed/created: ('/rhev/data-center/3e0452c8-21b5-4df1-aced-44bc4c568229/eb317662-1dab-458b-b9dd-82634e6222ae/images/43cfaf08-c75c-4e03-a0c8-58d631fac864',)


since this is the second time the exact same things happens to me, I doubt it's really a storage problem
Comment 4 Allon Mureinik 2013-11-05 10:08:34 EST
Edu, related to One Shot Prepare?
Comment 5 Eduardo Warszawski 2013-11-20 03:15:06 EST
(In reply to Allon Mureinik from comment #4)
> Edu, related to One Shot Prepare?

No.
From the Traceback in comment #1 is obvious that the code running does not include the oneShot prepare changes.
How can be it related?
Please use git.
Comment 6 Sergey Gotliv 2013-12-17 10:10:48 EST
This is a duplicate of BZ#1026697. 
The workaround is to put host on maintenance and then activate it again.

*** This bug has been marked as a duplicate of bug 1026697 ***
Comment 7 Allon Mureinik 2013-12-19 04:23:53 EST
Removing the "Reopened" keyword - this BZ was moved from CLOSED to ON_QA.
Comment 8 Sandro Bonazzola 2013-12-19 09:24:47 EST
oVirt 3.3.2 has been released resolving the problem described in this bug report.

Note You need to log in before you can comment on or make changes to this bug.