Bug 1026293 - Deployment is not processed when FSW is started with port offset
Deployment is not processed when FSW is started with port offset
Status: CLOSED NOTABUG
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ER7
: ---
Assigned To: Kurt T Stam
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 06:18 EST by Stefan Bunciak
Modified: 2015-08-02 19:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 11:30:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Bunciak 2013-11-04 06:18:28 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install FSW
2. Change dtgov-ui and sramp-ui properties to use proper ports
3. start FSW with port offset: "./standalone.sh -Djboss.socket.binding.port-offset=1"
4. add new deployment e.g. via dtgov-ui

Actual results:
* SimpleReleaseProcess is not kicked off, no deployment is processed, no errors in server log

Expected results:
* Deployment is successfully processed

Additional info:
Comment 2 Kurt T Stam 2013-11-07 14:19:54 EST
For this to work you will need to set three more properties in the dtgov.properties

sramp.repo.url=http://localhost:8081/s-ramp-server
governance.url=http://localhost:8081/dtgov
dtgov.ui.url=http://localhost:8081/dtgov-ui
Comment 3 Stefan Bunciak 2013-11-25 10:31:23 EST
This workaround helped a bit, but only moved me towards a different exception: 

Endpoint http://192.168.107:8080/dtgov/rest/deploy/qa/88574fab-8bb0-48b7-9b9c-a412875f559a could not be reached due to java.lang.NumberFormatException: For input string: "7080/". See the stack trace: http://pastebin.test.redhat.com/178290

In this case a changed the URL, not the ports but this shouldn't matter.
I've updated dtgov-ui.properties, dtgov.properties, sramp-ui.properties with appropriate urls.
Comment 4 Kurt T Stam 2013-11-25 11:23:46 EST
Hi Stefan, I think you have a typo in the pastebin it says: http://192.168.107:8080. This is not a valid IP address.
Comment 5 Stefan Bunciak 2013-11-26 04:31:42 EST
Yes, you were right, I had a typo in ip address. 
But after fixing ip address the error message still occurs: http://pastebin.test.redhat.com/178479

My guess is that the deployment process failed even before trying to establish some kind of connection.
Comment 6 Kurt T Stam 2013-11-26 09:46:08 EST
Hi I think this is related to parsing a RHQ target - nothing to with a port offset. Easy fix. Let me update the title though.
Comment 7 Kurt T Stam 2013-11-26 10:04:14 EST
Actually Stefan, the rhq target config expects the url part without a trailing slash '/'. I guess we should strip it off when it is there. Can you remove the trailing slash and try again?
Comment 8 Stefan Bunciak 2013-11-26 10:36:37 EST
Removing the trailing slash did the trick. Now the workflow works as expected.

Note You need to log in before you can comment on or make changes to this bug.