Bug 1026306 - Tools iso gets mounted to untooled VM even when CD is unchecked in "Run Once" dialog
Tools iso gets mounted to untooled VM even when CD is unchecked in "Run Once"...
Status: CLOSED DUPLICATE of bug 1054743
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity low
: ---
: 3.5.0
Assigned To: Martin Betak
virt
:
Depends On: 1054743
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 06:40 EST by David Jaša
Modified: 2014-03-26 09:04 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-26 09:04:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 25957 None None None Never

  None (edit)
Description David Jaša 2013-11-04 06:40:48 EST
Description of problem:
Auto-attaching latest tools iso for untooled Windows VMs is a nice thing to do when doing a generic "start VM" action but it's quite misleading when it kicks in as a result of "Run Once" action with CD to attach leaved as unchecked - the VM configuration should literally match what is entered in "Run Once" dialog (and the tools CD should be enabled by default there)

Version-Release number of selected component (if applicable):
is20.2 / rhevm-backend-3.3.0-0.30.beta1.el6ev.noarch

How reproducible:
always

Steps to Reproduce:
1. have a Windows VM
2. go to Run Once dialog, expand Boot Options
3. check if "Attach CD" is checked or not
4. uncheck "Attache CD" if checked, hit OK
5. check if VM has CD attached (vdsm.log, libvirt xml, qemu cli, ...)

Actual results:
3. "Attach CD" is unchecked
5. CD is actually attached

Expected results:
3. "Attach CD" should be checked and latest tools (the ones that get attached automagically) should be checked
5. VM should start without CD attached

Additional info:
Comment 1 Michal Skrivanek 2013-11-12 08:14:42 EST
we probably shouldn't do that when explicitly removed cdrom
Comment 2 Michal Skrivanek 2014-03-26 09:03:28 EDT
depends on refactoring done in bug 1054743 which is too risky to backport this late in 3.4 cycle. postponing and moving to MODIFIED for 3.5
Comment 3 Michal Skrivanek 2014-03-26 09:04:17 EDT

*** This bug has been marked as a duplicate of bug 1054743 ***

Note You need to log in before you can comment on or make changes to this bug.