Bug 102632 - Showing autohide panels is a bit jumpy
Showing autohide panels is a bit jumpy
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
: MoveUpstream, Triaged
: 102629 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-19 02:17 EDT by Nils Philippsen
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.4.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-02 10:50:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2003-08-19 02:17:16 EDT
Description of problem:

When showing an autohide panel, it seems to move a little bit orthogonally to
the movement direction before and while moving. When coming to rest, it is in
the correct position. E.g. a panel on the left side would move like this
(B=beginning, E=end position):

B           E
|           |
+-----------+

It's only about 5 pixels (too quick to count), but noticable.

Version-Release number of selected component (if applicable):

gnome-panel-2.3.6.2-3

How reproducible:

Always

Steps to Reproduce:
1. Make panel non-expanded, autohide
2. Make it show
    
Actual results:

See above.

Expected results:

Panel moves without offset

Additional info:

With the old GNOME version, the movement seemed more smooth (more steps while
moving) and I can't find where I can turn the old behaviour back on. I tried to
set GConf key /apps/panel/global/panel_animation_speed to "panel-speed-slow",
but to no avail.
Comment 1 Havoc Pennington 2003-08-19 11:49:52 EDT
Well there isn't going to be a "fix my bug please" gconf key ;-)
Comment 2 George Lebl 2003-08-19 13:26:22 EDT
Should be fixed upstream I think last week.
Comment 3 Nils Philippsen 2003-11-12 08:52:07 EST
Changed product to Fedora Core.

For me the problem is still there. The movement goes roughly like
(vertical, right bound panel), the unwanted vertical is greater when
showing the panel:

Showing the panel (states 1 through 4):

 3
| ^
| |
| |
v |
2/4<-----1

Hiding the panel (states 1 through 4):

1-------2/4
        | ^
        | |
        v |
         3
Comment 4 Bart Martens 2003-12-20 04:00:23 EST
Same problem here. The whole toolbar and the icons on it shake
horizontally.

But, a simimar problem occurs with expanded toolbar. The workspace
switcher shakes horizontally. Workaround: move the workspace switcher
and the window list, to insert some space.
Comment 5 Bart Martens 2004-02-13 12:46:59 EST
Known upstream, see:
http://bugzilla.gnome.org/show_bug.cgi?id=127758

There is a workaround available. Joseph Mocker wrote:
"I just changed the panel background from
"None (use system theme)" to "Solid Color" and it appears
to fix the problem. I just set the color to the
same as the system theme and left the Style at
100% Opaque."
Comment 6 Nils Philippsen 2004-02-13 17:16:30 EST
This workaround definitely doesn't work for me, just tried it with
gnome-panel-2.4.0-3 -- perhaps this only works with CVS?
Comment 7 Nils Philippsen 2004-02-13 17:51:24 EST
Hmm, maybe it's because the (jumpy) panels (left + right) are
"sitting" on top of the (also auto-hiding) bottom panel:

Hidden:

    ,------------------.
    |       TOP        |
    +------------------.
    |                  |
    |                  +---.
,---+                  | R |
| L |                  | I |
| E |      SCREEN      | G |
| F |                  | H |
| T |                  | T |
`---+------------------+---´
    |      BOTTOM      |
    `------------------´

Unhidden:

    ,------------------.
    |       TOP        |
    +--------------+---+
    +---+          | R |
    | L |          | I |
    | E |  SCREEN  | G |
    | F +----------+ H |
    | T |  BOTTOM  | T |
    `---+----------+---´

I can provide screen shots if necessary.
Comment 8 Bart Martens 2004-02-15 08:12:47 EST
George, comment #2 : any pointer to the solution?

Nils, comment #6 : I have not tried it with CVS. It should work with
gnome-applets-2.4.1-1
gnome-panel-2.4.0-3

This bug may be related to bug #102629.
Comment 9 Mark McLoughlin 2004-02-20 08:33:05 EST
Thanks for all the info, I think we have a fair idea of what the
problem is. Lets track this upstream:

http://bugzilla.gnome.org/show_bug.cgi?id=127758

Comment 10 Bart Martens 2004-02-24 06:25:23 EST
Patch submitted upstream.
Comment 11 Bart Martens 2004-02-24 08:02:31 EST
Repeating the link to the upstream bug report, copying from comment #5.
http://bugzilla.gnome.org/show_bug.cgi?id=127758
Comment 12 Bart Martens 2004-02-27 05:10:44 EST
Mark, I don't think you're on the cc of the upstream bug report. Have
you checked it recently? You wanted to add the patch to the update
before pushing it to final... remember?
http://www.redhat.com/archives/fedora-test-list/2004-February/msg01580.html

Nils, maybe you can help to get the patch validated or rejected
upstream? You reported both bugs, so you may be interested to see them
solved.
Comment 13 Mark McLoughlin 2004-02-27 05:21:16 EST
Bart: I'm on gnome-panel-maint@bugzilla.gnome.org. I won't forget,
just been too busy so far this week.
Comment 14 Mark McLoughlin 2004-02-27 10:23:53 EST
Re-opening this since it'll be in the update released on Monday
(2004-03-01).

Nils reports that Bart's patch works perfectly.
Comment 15 Mark McLoughlin 2004-03-02 10:48:50 EST
Okay, a gnome-panel Fedora Core 1 Update (2.4.2-3) with a fix
for this bug is now available from:

   http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/
Comment 16 Bart Martens 2004-03-03 16:24:16 EST
*** Bug 102629 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.