Bug 1026328 - UnboundLocalError: local variable 'found' referenced before assignment
UnboundLocalError: local variable 'found' referenced before assignment
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
20
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 07:45 EST by Kamil Páral
Modified: 2013-11-19 00:31 EST (History)
7 users (show)

See Also:
Fixed In Version: rpmlint-1.5-5.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-16 02:09:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2013-11-04 07:45:37 EST
Description of problem:
$ koji download-build --arch=i686 cinnamon-2.0.10-1.fc19
$ rpmlint ./cinnamon-2.0.10-1.fc19.i686.rpm 
cinnamon.i686: E: explicit-lib-dependency accountsservice-libs
cinnamon.i686: E: explicit-lib-dependency librsvg2(x86-32)
cinnamon.i686: W: obsolete-not-provided cinnamon-2d
cinnamon.i686: W: obsolete-not-provided cinnamon-settings
cinnamon.i686: W: obsolete-not-provided cinnamon-menu-editor
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_calendar.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_desklets.py 0644L /usr/bin/env
cinnamon.i686: E: backup-file-in-package /usr/lib/cinnamon-settings/cinnamon-settings.py.orig
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/bin/SettingsWidgets.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/bin/XletSettingsWidgets.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_screensaver.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_fonts.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_desktop.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_hotcorner.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_windows.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_general.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_keyboard.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_applets.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_default.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_tiling.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_mouse.py 0644L /usr/bin/env
cinnamon.i686: W: dangling-relative-symlink /etc/xdg/menus/cinnamon-applications-merged applications-merged
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_user.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_workspaces.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_themes.py 0644L /usr/bin/env
cinnamon.i686: W: non-conffile-in-etc /etc/xdg/menus/cinnamon-applications.menu
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_effects.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_panel.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_info.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_extensions.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/modules/cs_backgrounds.py 0644L /usr/bin/env
cinnamon.i686: E: non-executable-script /usr/lib/cinnamon-settings/bin/ExtensionCore.py 0644L /usr/bin/env
cinnamon.i686: W: no-manual-page-for-binary cinnamon-desktop-editor
cinnamon.i686: W: no-manual-page-for-binary cinnamon-screensaver-lock-dialog
cinnamon.i686: W: no-manual-page-for-binary cinnamon-session-cinnamon
cinnamon.i686: W: no-manual-page-for-binary cinnamon-settings-users
cinnamon.i686: W: no-manual-page-for-binary cinnamon-looking-glass
cinnamon.i686: W: no-manual-page-for-binary cinnamon-json-makepot
cinnamon.i686: W: no-manual-page-for-binary cinnamon-session-cinnamon2d
cinnamon.i686: W: desktopfile-without-binary /usr/share/applications/cinnamon-add-panel-launcher.desktop /usr/share/cinnamon/applets/panel-launchers@cinnamon.org/cinnamon-add-panel-launcher.py
0 packages and 0 specfiles checked; 27 errors, 13 warnings.
Traceback (most recent call last):
  File "/usr/bin/rpmlint", line 378, in <module>
    main()
  File "/usr/bin/rpmlint", line 168, in main
    runChecks(pkg)
  File "/usr/bin/rpmlint", line 228, in runChecks
    check.check(pkg)
  File "/usr/share/rpmlint/AbstractCheck.py", line 83, in check
    self.check_file(pkg, filename)
  File "/usr/share/rpmlint/MenuXDGCheck.py", line 54, in check_file
    if not found:
UnboundLocalError: local variable 'found' referenced before assignment


This happens very often for various builds.

Version-Release number of selected component (if applicable):
rpmlint-1.5-4.fc20.noarch

How reproducible:
always
Comment 2 Kamil Páral 2013-11-11 04:59:25 EST
A lot of AutoQA tests crash every day because of this bug. Could somebody please release an updated rpmlint version? Thanks a lot.
Comment 3 Fedora Update System 2013-11-11 10:56:25 EST
rpmlint-1.5-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/rpmlint-1.5-5.fc19
Comment 4 Fedora Update System 2013-11-11 10:56:46 EST
rpmlint-1.5-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rpmlint-1.5-5.fc18
Comment 5 Fedora Update System 2013-11-11 10:57:05 EST
rpmlint-1.5-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/rpmlint-1.5-5.fc20
Comment 6 Fedora Update System 2013-11-11 19:30:40 EST
Package rpmlint-1.5-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpmlint-1.5-5.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21092/rpmlint-1.5-5.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-11-16 02:09:33 EST
rpmlint-1.5-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-11-19 00:25:48 EST
rpmlint-1.5-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-11-19 00:31:44 EST
rpmlint-1.5-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.