Bug 1026344 - Disconnect storage pool in case of unsuccessful hosted-engine setup.
Disconnect storage pool in case of unsuccessful hosted-engine setup.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
unspecified
Unspecified Unspecified
high Severity medium
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
movciari
integration
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 08:34 EST by Leonid Natapov
Modified: 2014-01-21 11:55 EST (History)
6 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-setup-1.0.0-0.10.1.rc.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:55:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21866 None None None Never
oVirt gerrit 21915 None None None Never

  None (edit)
Description Leonid Natapov 2013-11-04 08:34:32 EST
If hosted engine setup was for some reason unsuccessful we still have storage pool connected as a leftover of previous setup. 
If user tries to run setup again he will get an error:

 [ ERROR ] The following storage pool has been found connected: dff9559f-3587-41fd-8af2-5d71fc902f5c
[ ERROR ] Failed to execute stage 'Environment customization': Cannot setup Hosted Engine with connected storage pools

We should disconnect storage pool that we created in case of  unsuccessful setup.
Comment 1 Sandro Bonazzola 2013-11-05 10:27:09 EST
As workaround you can just reboot or use a script like this:

 #!/bin/sh
 spUUID=`vdsClient -s localhost getConnectedStoragePoolsList`
 sdUUID=`vdsClient -s localhost getStorageDomainsList $spUUID`
 vdsClient -s localhost spmStop $spUUID
 vdsClient -s localhost disconnectStoragePool $spUUID 1 $sdUUID

where 1 is the host id for first host.
Postponing to 3.3.1
Comment 2 Ofer Schreiber 2013-11-26 08:20:24 EST
I've encountered the same issue (after a failed run due to wrong cpu type).
Comment 3 Sandro Bonazzola 2013-12-02 08:43:50 EST
Patch merged on upstream master and 1.0 branches
Comment 5 errata-xmlrpc 2014-01-21 11:55:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0083.html

Note You need to log in before you can comment on or make changes to this bug.