Bug 1026355 - Add support for own types in JaxbSerializationProvider
Add support for own types in JaxbSerializationProvider
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity low
: ER5
: 6.0.0
Assigned To: Marco Rietveld
Ivo Bek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 08:47 EST by Ivo Bek
Modified: 2016-09-20 01:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Bek 2013-11-04 08:47:36 EST
Description of problem:

When we use own type in the parameters of StartProcessCommand, the context has to know about it. The class then cannot be used just because there is no possibility how to add the own classes into the context.
Comment 1 Ivo Bek 2013-11-04 09:08:46 EST
I propose something like:

public static String convertJaxbObjectToString(Object object, Class... classes)
            throws JAXBException {

Marshaller marshaller = JAXBContext.newInstance(ArrayUtils.addAll(jaxbClasses, classes)).createMarshaller();
Comment 3 Ivo Bek 2013-12-09 09:59:41 EST
Verified in BPMS 6.0.0.ER5

Note You need to log in before you can comment on or make changes to this bug.