Bug 1026356 - anaconda: Fail to create root partition on LVM when booting via iSCSI
anaconda: Fail to create root partition on LVM when booting via iSCSI
Status: CLOSED DUPLICATE of bug 1022899
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Bruno Goncalves
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 08:49 EST by Bruno Goncalves
Modified: 2013-11-06 10:57 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 10:57:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (9.27 KB, text/plain)
2013-11-04 08:51 EST, Bruno Goncalves
no flags Details
ifcfg.log (10.63 KB, text/plain)
2013-11-04 08:52 EST, Bruno Goncalves
no flags Details
packaging.log (19.03 KB, text/plain)
2013-11-04 08:52 EST, Bruno Goncalves
no flags Details
program.log (34.78 KB, text/plain)
2013-11-04 08:53 EST, Bruno Goncalves
no flags Details
storage.log (158.13 KB, text/plain)
2013-11-04 08:53 EST, Bruno Goncalves
no flags Details
syslog (136.91 KB, text/plain)
2013-11-04 08:54 EST, Bruno Goncalves
no flags Details

  None (edit)
Description Bruno Goncalves 2013-11-04 08:49:35 EST
Description of problem:
Trying to install a system with iSCSI boot causes the following error


Progress
Setting up the installation environment
.
** (anaconda:1373): WARNING **: Could not open X display
An unknown error has occured, look at the /tmp/anaconda-tb* file(s) for more details

===============================================================================
An unknown error has occurred
===============================================================================
anaconda 19.31.32-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicelibs/lvm.py", line 439, in lvactivate
    raise LVMError("lvactivate failed for %s: %s" % (lv_name, msg))
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2684, in _setup
    lvm.lvactivate(self.vg.name, self._name)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 718, in setup
    self._setup(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 526, in execute
    self.device.setup(orig=True)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 306, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 170, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 144, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
LVMError: lvactivate failed for lv_root: running lvm lvchange -a y --config  devices { filter=["r|/360a980003246694a412b424f41657a35$|","r|/sdb$|","r|/sdd$|"] }  vg_storageqe02/lv_root failed

Version-Release number of selected component (if applicable):
anaconda 19.31.32-1

How reproducible:
100%

Steps to Reproduce:
1. Try to install RHEL7 on iSCSI boot device
Comment 1 Bruno Goncalves 2013-11-04 08:51:37 EST
Created attachment 819151 [details]
anaconda.log
Comment 2 Bruno Goncalves 2013-11-04 08:52:08 EST
Created attachment 819152 [details]
ifcfg.log
Comment 3 Bruno Goncalves 2013-11-04 08:52:43 EST
Created attachment 819153 [details]
packaging.log
Comment 4 Bruno Goncalves 2013-11-04 08:53:11 EST
Created attachment 819154 [details]
program.log
Comment 5 Bruno Goncalves 2013-11-04 08:53:51 EST
Created attachment 819155 [details]
storage.log
Comment 6 Bruno Goncalves 2013-11-04 08:54:19 EST
Created attachment 819156 [details]
syslog
Comment 7 David Lehman 2013-11-06 10:57:45 EST

*** This bug has been marked as a duplicate of bug 1022899 ***

Note You need to log in before you can comment on or make changes to this bug.