Bug 1026395 - Missing a method to get a process variable via JBPM Remote API
Missing a method to get a process variable via JBPM Remote API
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER5
: 6.0.0
Assigned To: Marco Rietveld
Ivo Bek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 09:43 EST by Ivo Bek
Modified: 2016-09-20 01:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Bek 2013-11-04 09:43:30 EST
Description of problem:

We use RemoteRestSessionFactory to create RuntimeEngine and then KSession but there is no method to get a process variable. The given process instance cannot be type cast to WorkflowProcessInstance, so I'm aware there is no possibility to use JBPM Remote API to get a process variable.
Comment 1 Marek Baluch 2013-11-12 04:02:25 EST
Hi Marco,

would you mind explaining why this issue was marked with devel_ack-?

I asked Kris some time ago what is the recommended approach to get information about the process (variables, visited nodes, etc.) when using REST or JMS but I haven't got an answer yet. I know you can use the VariableInstanceLog and similar classes to get this information but I do not think that users using REST or JMS will have the information about the database which is required.

Thank you.

Regards
Marek
Comment 2 Marco Rietveld 2013-11-13 05:58:53 EST
Hi Marek, 

I've added devel_ack- because I see this as a request for a new feature and not as a bug. 

Users are unfortunately constrained to the pure REST api or pure JMS api if they want to access history/variable information. 

However, I'm leaving the last word to Kris: I've just e-mailed him asking him to comment on this issue, one way or the other. 

I do agree with the need for this feature -- I will definitely add it with (jBPM) 6.1. However, IMHO, the problem is not severe enough to be included in jBPM/BPMS 6.x.
Comment 4 Marco Rietveld 2013-11-15 07:16:38 EST
I had a little bit of extra time to implement this and, once I thought about it, it was easier than expected -- and adding it helped me test a couple of other fixes as well. 

So I changed the devel_ack (-> +) and pushed the commits. 

Again, the main reason for the devel_ack- was the priority of the issue, given that this issue does not affect whether or not the API works, just which features are availability (as opposed to other issues).
Comment 5 Ivo Bek 2013-12-09 06:45:05 EST
Verified in BPMS 6.0.0.ER5

Note You need to log in before you can comment on or make changes to this bug.