Bug 1026402 - JBPM Remote API cannot be used with own types of classes
JBPM Remote API cannot be used with own types of classes
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Marco Rietveld
Ivo Bek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 09:55 EST by Ivo Bek
Modified: 2016-09-20 01:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Bek 2013-11-04 09:55:57 EST
Description of problem:

When I put a parameter of unknown type to the parameters for starting a process instance, I'll receive an expected exception JAXBException: class org.jboss.qa.bpms.jbpm.integration.MyType nor any of its super class is known to this context.
I propose to add a parameter of additional classes to the constructors of RemoteRestSessionFactory, and RemoteJmsRuntimeEngineFactory. Then, use the classes for JAXBContext.
Comment 3 Marco Rietveld 2013-11-15 07:14:07 EST
The client side is fixed for this -- however, 1026384, which is a related to this because it's the issue of whether or not the "own type of class" is correctly deserialized/unmarshalled on the server side, is still an issue. 

In order not to complicate things (and have duplicate/similar issues open), I'm closing this and will label/tag all fixes for the server side with the BZ-1026348 text.
Comment 5 Marco Rietveld 2013-11-18 09:06:57 EST
Correction, I meant to reference BZ-10263_84_ in the comment above.
Comment 8 Ivo Bek 2013-12-09 09:11:12 EST
Verified in BPMS 6.0.ER5

Only the unmarshalling doesn't work due to BZ 1026384 as we discussed with Marco.

Note You need to log in before you can comment on or make changes to this bug.