Bug 1026411 - Drupal QuickStart no longer working
Drupal QuickStart no longer working
Status: CLOSED DUPLICATE of bug 1018387
Product: OpenShift Online
Classification: Red Hat
Component: Templates (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 10:16 EST by Jonathan Hindi
Modified: 2013-11-04 12:27 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 12:27:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Hindi 2013-11-04 10:16:09 EST
Description of problem:
Trying to install Drupal on openshift not working using 
"rhc app create drupal php-5.3 mysql-5 cron --from-code=git://github.com/openshift/drupal-quickstart.git"

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Run rhc app create drupal php-5.3 mysql-5 cron --from-code=git://github.com/openshift/drupal-quickstart.git

Actual results:
Give an error, after running the same command again with --trace got the following: 

$:~ jonathanhindi$ rhc app create drupal php-5.3 mysql-5 cron --from-code=git://github.com/openshift/drupal-quickstart.git --trace
Using mysql-5.1 (MySQL 5.1) for 'mysql-5'
Using cron-1.4 (Cron 1.4) for 'cron'

Application Options
-------------------
  Domain:      drupal
  Cartridges:  php-5.3, mysql-5.1, cron-1.4
  Source Code: git://github.com/openshift/drupal-quickstart.git
  Gear Size:   default
  Scaling:     no

Creating application 'drupal' ... /Library/Ruby/Gems/2.0.0/gems/rhc-1.15.6/lib/rhc/rest/client.rb:613:in `handle_error!': The initial build for the application failed: Shell command '/sbin/runuser -s /bin/sh 5277b630e0b8cdddad000347 -c "exec /usr/bin/runcon 'unconfined_u:system_r:openshift_t:s0:c2,c574' /bin/sh -c \"gear postreceive >> /tmp/initial-build.log 2>&1\""' returned an error. rc=255 (RHC::Rest::ValidationException)

.Last 10 kB of build output:
Stopping PHP cartridge
Syntax error on line 2 of /var/lib/openshift/5277b630e0b8cdddad000347/php/configuration/etc/conf.d/openshift.conf:
DocumentRoot must be a directory
httpd (no pid file) not running
Stopping Cron cartridge
Stopping MySQL cartridge
Building PHP cartridge
Checking pear: pear.drush.org/drush

Attempting to discover channel "pear.drush.org"...
downloading channel.xml ...
Starting to download channel.xml (804 bytes)
....done: 804 bytes
Auto-discovered channel "pear.drush.org", alias "drush", adding to registry
downloading drush-6.1.0.0.tgz ...
Starting to download drush-6.1.0.0.tgz (504,788 bytes)
...done: 504,788 bytes
install ok: channel://pear.drush.org/drush-6.1.0.0

Download and install the latest stable version of Drupal

copy(/tmp/drush_tmp_1383577186_5277b662e08d5/drupal): failed to open   [warning]
stream: No such file or directory filesystem.inc:257
Project drupal (7.23) could not be downloaded to                         [error]
/var/lib/openshift/5277b630e0b8cdddad000347/app-root/data/downloads/drupal.
ERROR: Unable download and install Drupal.
An error occurred executing 'gear postreceive' (exit code: 7)
Error message: Failed to execute action hook 'build' for 5277b630e0b8cdddad000347 application drupal
Comment 1 Dan McPherson 2013-11-04 12:27:48 EST

*** This bug has been marked as a duplicate of bug 1018387 ***

Note You need to log in before you can comment on or make changes to this bug.