Bug 1026440 - Please update antlr3 to version 3.5.1 and include C++ runtime [NEEDINFO]
Please update antlr3 to version 3.5.1 and include C++ runtime
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: antlr3 (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Colin Walters
Fedora Extras Quality Assurance
: Reopened
Depends On: 892478
Blocks: 979166
  Show dependency treegraph
 
Reported: 2013-11-04 11:13 EST by Pavel Alexeev
Modified: 2015-08-31 22:18 EDT (History)
5 users (show)

See Also:
Fixed In Version: antlr3-3.5.2-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-31 22:18:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
i: needinfo? (walters)


Attachments (Terms of Use)

  None (edit)
Description Pavel Alexeev 2013-11-04 11:13:59 EST
We are working on unbundling libraries from tora (bz#979166). Ivan Brezina - the upstream author kindly resolve most of that https://sourceforge.net/p/tora/bugs/873/?page=1 .
But there antlr3 cpp runtime bindings required 3.5.1 version.

Is it possible update package in Fedora and include cpp runtime in that?
Comment 1 Christopher Meng 2014-03-22 10:09:10 EDT
Can you update?
Comment 2 Milos Jakubicek 2014-03-22 12:42:55 EDT
Where is the info on the C++ target requiring 3.5.1?

I'm definitely not willing to update to 3.5.* as it would not be compatible with the current C target -- but I'm willing to include the current (limited and unfinished -- not tree walkers) C++ target as it is, if you assure me it works with 3.4.
Comment 3 Milos Jakubicek 2014-03-26 04:26:23 EDT
Ok, things look a bit better now, antlr 3.5.2 has been released including updates for the C target. I will try to update the Fedora packages within a week.
Comment 4 Christopher Meng 2014-03-26 04:42:22 EDT
I hope EPEL7 can receive the latest version.

You don't need to update f20 branch IMO, but that's your choice.

Thank you.
Comment 5 Pavel Alexeev 2014-08-18 07:05:02 EDT
I see only 3.5 version in rawhide. Is it intended?

# yum list --enablerepo=rawhide '*antlr3*'
ant-antlr3.noarch                 20110110-9.fc21        rawhide
ant-antlr3-javadoc.noarch         20110110-9.fc21        rawhide
antlr3-C.i686                     3.4-1.fc21             rawhide
antlr3-C-devel.i686               3.5-1.fc21             rawhide
antlr3-C-devel.x86_64             3.5-1.fc21             rawhide
antlr3-C-docs.noarch              3.5-1.fc21             rawhide
antlr3-java.noarch                3.5-1.fc21             rawhide
antlr3-javadoc.x86_64             3.5-1.fc21             rawhide
antlr3-javascript.noarch          3.1-15.fc20            fedora 
antlr3-tool.noarch                3.5-1.fc21             rawhide
antlr32-java.noarch               3.2-5.fc21             rawhide
antlr32-javadoc.noarch            3.2-5.fc21             rawhide
antlr32-maven-plugin.noarch       3.2-5.fc21             rawhide
antlr32-tool.noarch               3.2-5.fc21             rawhide
Comment 6 Jaroslav Reznik 2015-03-03 11:56:42 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Note You need to log in before you can comment on or make changes to this bug.