Bug 1026450 - Subscription management service (candlepin) version isn't always known
Subscription management service (candlepin) version isn't always known
Status: CLOSED DUPLICATE of bug 843649
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-11-04 11:52 EST by Matt Reid
Modified: 2014-01-13 12:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-13 12:57:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2013-11-04 11:52:42 EST
Description of problem:
In the About dialog in the GUI, and in the version module in the CLI, we attempt to provide users with the version of candlepin that they're registered with. Off hand, I've always seen it returned as Unknown, and assumed it needed a newer CP build to work, but this was added to the GUI quite some time ago I think, and I feel like by now it should be in Prod.

Running this today, I got Unknown back from SAM 1.1, and Portal prod, and got an actual version number back from a dev's local instance.

Is this functioning as it should, or should it have returned a version number for more than 1 of the 3 servers I tried? Does it depend on minimum version of CP before it returns version info?

* Registered to SAM 1.1   
[root@rhel-dev3 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: Unknown
subscription-manager: 1.10.5-1.git.18.a5876d1.el6
python-rhsm: 1.10.5-1.git.7.690d461.el6
     
* Registered to Prod Portal
[root@rhel-dev3 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: Unknown
subscription-manager: 1.10.5-1.git.18.a5876d1.el6
python-rhsm: 1.10.5-1.git.7.690d461.el6
     
* Registered to mstead-cp
[root@rhel-dev3 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.29-1
subscription-manager: 1.10.5-1.git.18.a5876d1.el6
python-rhsm: 1.10.5-1.git.7.690d461.el6


Steps to Reproduce:
1. Register with a server
2. Either run subscription-manager version, or open the About dialog

Actual results:
Candlepin version sometimes returned as Unknown

Expected results:
Candlepin version should be listed under subscription management service version

Additional info:
Having issues registering with Stage, so I can't check what's returned there
Comment 1 Matt Reid 2013-11-13 14:56:18 EST
Stage doesn't return a value for me either, just shows Unknown.
Comment 2 Carter Kozak 2013-12-20 12:18:51 EST
I think stage/prod blocks this call, we should probably move the bug to IT.
Comment 3 Carter Kozak 2014-01-13 12:57:46 EST

*** This bug has been marked as a duplicate of bug 843649 ***

Note You need to log in before you can comment on or make changes to this bug.