This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1026459 - org.ovirt.thread log message spam
org.ovirt.thread log message spam
Status: CLOSED DUPLICATE of bug 1025402
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity low
: ---
: 3.5.0
Assigned To: Allon Mureinik
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 12:32 EST by Greg Sheremeta
Modified: 2016-02-10 14:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-05 07:59:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
org.ovirt.thread log spam sample (49.75 KB, text/plain)
2013-11-04 12:32 EST, Greg Sheremeta
no flags Details

  None (edit)
Description Greg Sheremeta 2013-11-04 12:32:29 EST
Created attachment 819278 [details]
org.ovirt.thread log spam sample

Description of problem:
Leaving ovirt-engine (dev mode) running for a while, eventually log spam appears:

2013-11-04 12:26:25,089 INFO  [org.ovirt.engine.core.bll.IsoDomainListSyncronizer] (org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.org.ovirt.thread.pool-6-thread-13) Finished automatic refresh process for ISO file type with success, for storage domain id 65648f67-5971-45fb-8f7d-94a3861eb9b4.

org.ovirt.thread spam happens for a few different background threads afaict.

Version-Release number of selected component (if applicable):
N/A, master

How reproducible:
always

Steps to Reproduce:
1. start ovirt-engine
2. log in to Webadmin
3. let ovirt-engine sit for about 5 minutes.

Actual results:
org.ovirt.thread log spam appears.

Expected results:
no org.ovirt.thread log spam.

Additional info:
samples attached.
Comment 1 Allon Mureinik 2013-11-05 07:59:17 EST
This is a regression in the ThreadPoolUtil, not really related to the IsoDomainListSyncronizer.
Closing as duplicate of bug 1025402

*** This bug has been marked as a duplicate of bug 1025402 ***

Note You need to log in before you can comment on or make changes to this bug.