Bug 1026462 - Uncommenting "- hammer_cli_katello_bridge" in /etc/foreman/cli_config.yml causes error when running hammer
Uncommenting "- hammer_cli_katello_bridge" in /etc/foreman/cli_config.yml cau...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Martin Bacovsky
Kedar Bidarkar
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 12:38 EST by Jason Montleon
Modified: 2016-04-22 12:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-14 04:02:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 3580 None None None 2016-04-22 12:18 EDT

  None (edit)
Description Jason Montleon 2013-11-04 12:38:13 EST
Description of problem:
Uncommenting "- hammer_cli_katello_bridge" in /etc/foreman/cli_config.yml causes error when running hammer. As long as the line remains commented it works properly.

Version-Release number of selected component (if applicable):
rubygem-hammer_cli_foreman-0.0.9-2.el6sat.noarch
rubygem-hammer_cli-0.0.8-2.el6sat.noarch
rubygem-hammer_cli_katello_bridge-0.0.6-2.el6sat.noarch


How reproducible:
Always

Steps to Reproduce:
1. In katello/hammer
2. Uncomment "- hammer_cli_katello_bridge" in /etc/foreman/cli_config.yml
3. Run hammer

Actual results:
[root@mdp2-1 katello]# hammer
Error: undefined method `find_by_name' for Gem::Specification:Class
[root@mdp2-1 katello]# hammer --verbose
[ INFO 2013-11-04 12:35:49 Init] Configuration from the file /etc/foreman/cli_config.yml has been loaded
[ INFO 2013-11-04 12:35:49 Init] Extension module hammer_cli_foreman loaded
[ERROR 2013-11-04 12:35:49 Init] Error while loading module hammer_cli_katello_bridge
[ERROR 2013-11-04 12:35:49 Exception] Error: undefined method `find_by_name' for Gem::Specification:Class
Error: undefined method `find_by_name' for Gem::Specification:Class
[ERROR 2013-11-04 12:35:49 Exception] 

NoMethodError (undefined method `find_by_name' for Gem::Specification:Class):
    /usr/lib/ruby/gems/1.8/gems/hammer_cli_katello_bridge-0.0.6/lib/hammer_cli_katello_bridge.rb:81
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
    /usr/lib/ruby/gems/1.8/gems/hammer_cli-0.0.8/bin/hammer:52
    /usr/lib/ruby/gems/1.8/gems/hammer_cli-0.0.8/bin/hammer:50:in `each'
    /usr/lib/ruby/gems/1.8/gems/hammer_cli-0.0.8/bin/hammer:50
    /usr/bin/hammer:19:in `load'
    /usr/bin/hammer:19


Expected results:
hammer runs normally.

Additional info:
Comment 1 RHEL Product and Program Management 2013-11-04 12:55:08 EST
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Martin Bacovsky 2013-11-05 05:04:30 EST
Created upstream bug http://projects.theforeman.org/issues/3580. The json definition file lookup works only on rubygems >= 2.0 (Ruby 1.9.2+). I will provide fix soon.
Comment 4 Martin Bacovsky 2013-11-11 03:12:11 EST
This issue is fixed in rubygem-hammer-cli-katello-bridge >= 0.0.7
Comment 7 Kedar Bidarkar 2014-08-14 02:58:20 EDT
Looks like we no longer have /etc/foreman/cli_config.yml

Please provide the verification steps, as the packages or files to verify this has changed.
Comment 8 Martin Bacovsky 2014-08-14 03:58:44 EDT
I'd suggest to run 'hammer -d' to see in the output what config files it reads. Then check there is no hammer-cli-katello-bridge to uncomment in them.
Comment 9 Dominic Cleal 2014-08-14 04:02:51 EDT
hammer-cli-katello-bridge has been deprecated and removed, hammer-cli-katello is the replacement and has QE coverage.

Note You need to log in before you can comment on or make changes to this bug.