Bug 1026465 - cannot revert bundle
cannot revert bundle
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Provisioning (Show other bugs)
JON 3.2
Unspecified Unspecified
high Severity high
: ER07
: JON 3.2.0
Assigned To: John Mazzitelli
Mike Foley
:
Depends On: 1026460
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 12:46 EST by John Mazzitelli
Modified: 2014-01-02 15:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1026460
Environment:
Last Closed: 2014-01-02 15:35:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2013-11-04 12:46:32 EST
+++ This bug was initially created as a clone of Bug #1026460 +++

try to revert a bundle version - you get this error on the server:

Caused by: java.lang.NullPointerException
        at org.rhq.enterprise.server.bundle.BundleManagerBean.getBundleDeploymentName(BundleManagerBean.java:413) [rhq-server.jar:4.9.0.JON320-SNAPSHOT]
Comment 1 John Mazzitelli 2013-11-04 12:47:37 EST
I'm going to fix this in the release/jon3.2.x branch - without this fix, bundle revert simply will never work
Comment 2 John Mazzitelli 2013-11-04 12:50:28 EST
git commit to release/jon3.2.x branch: 386ae73
Comment 3 Simeon Pinder 2013-11-19 10:48:07 EST
Moving to ON_QA as available for testing with new brew build.
Comment 4 Simeon Pinder 2013-11-22 00:13:42 EST
Mass moving all of these from ER6 to target milestone ER07 since the ER6 build was bad and QE was halted for the same reason.
Comment 5 Armine Hovsepyan 2013-11-26 05:37:48 EST
verified -> http://d.pr/i/Zbfv

Note You need to log in before you can comment on or make changes to this bug.