Bug 1026490 - my.cnf generated incorrectly after migration
my.cnf generated incorrectly after migration
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 14:14 EST by Stefanie Forrester
Modified: 2013-11-04 16:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 16:28:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefanie Forrester 2013-11-04 14:14:42 EST
Description of problem:

Mysql is unable to start on this gear, due to an incorrectly-generated my.cnf. This could be caused by an erb templating error in the migration script.

When I try to fix the config file manually, it's immediately replaced with the incorrect version again, so manual intervention isn't an option.

Version-Release number of selected component (if applicable):

2.0.34

How reproducible:

Not sure. I've only encountered one instance of this.

Steps to Reproduce:

The error can be confirmed on one host:

[root@ex-std-node194.prod ~]# grep mysql_error.log /var/lib/openshift/520bd8895973ca3977000196/mysql/conf/my.cnf
log-error=/mysql_error.log

Actual results:

log-error=/mysql_error.log

Expected results:

The correct path is
log-error=/var/lib/openshift/520bd8895973ca3977000196/mysql/log/mysql_error.log

Additional info:
Comment 1 Dan Mace 2013-11-04 16:28:51 EST
The gear's OPENSHIFT_MYSQL_DB_LOG_DIR variable was manually repaired, and no general problem was identified with other gears. Going to close this one.

Note You need to log in before you can comment on or make changes to this bug.