Bug 1026506 - CONFIG_SCHEDSTATS disabled in kernel
Summary: CONFIG_SCHEDSTATS disabled in kernel
Status: CLOSED DUPLICATE of bug 1013225
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-04 20:09 UTC by Andi Kleen
Modified: 2013-11-04 20:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 20:26:25 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andi Kleen 2013-11-04 20:09:17 UTC
Description of problem:

CONFIG_SCHEDSTATS is disabled in FC19 kernel
The optional has miniscule overhead, but is quite useful to analyze performance problems and should be enabled by default.


Version-Release number of selected component (if applicable):

FC19


How reproducible:

grep CONFIG_SCHEDSTATS /boot/config-$(uname -r)

cat /proc/self/sched

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Josh Boyer 2013-11-04 20:26:25 UTC
That's what the Kconfig option says, yes.  It seems in practice the overhead isn't minuscule, though I don't have the direct results.

*** This bug has been marked as a duplicate of bug 1013225 ***


Note You need to log in before you can comment on or make changes to this bug.